WordPress.org

Support

Support » Plugins and Hacks » Active Directory Integration » Can only authenticate one user

Can only authenticate one user

  • When using the test tool, I can authenticate one user, but no others. The user that was able to authenticate is a domain admin account. I tried another domain admin account and it didn’t work.

    I’ve tried setting Base DN to ou=xx,dc=yy,dc=zz.
    I’ve tried setting Base DN to just dc=yy, dc=zz.
    I’ve tried leaving Base DN blank.

    I get the same results, even with Base DN blank. That single user can authenticate but no others can. I tried adding the suffix @ourdomain.foo, but that broke the one user that could authenticate.

    Any ideas?

    http://wordpress.org/plugins/active-directory-integration/

Viewing 5 replies - 1 through 5 (of 5 total)
  • More data…

    I wrote a short PHP script to test ldap connectivity from this server.

    <?php
    $c = ldap_connect("myserver");
    $b = ldap_bind($c, "user1","password1");
    ?>

    works fine, but

    <?php
    $c = ldap_connect("myserver");
    $b = ldap_bind($c, "user2","password2");
    ?>

    throws an error…

    Warning: ldap_bind() [function.ldap-bind]: Unable to bind to server: Invalid credentials in [line of code in file]

    Okay, so I finally figured out that if I add @our.domain.foo as a suffix, then I can authenticate, but adding @domain.foo still doesn’t work. Now I’m trying to figure out how to allow only users in a particular OU.

    Feel free to jump in here… }:-)

    oh, and this PHP code works…

    <?php
    $c = ldap_connect("myserver");
    $b = ldap_bind($c, "user2@our.domain.foo","password2");
    ?>

    SOLVED!

    I was able to authenticate just employees by putting all employees into an AD group, checking the box under the Authorization tab that says ‘Users are authorized for login only when they are members of a specific AD group.’, and putting the group name in the blank. That killed my admin user, but now only employees can log in to WordPress.

    Thanks, me, you were a great help!!! }:-)

    LOL… nice. Thanks to YOU… well done. Now I need to ask a question for my own thread.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Can only authenticate one user’ is closed to new replies.
Skip to toolbar