Support » Networking WordPress » Can only access intranet website from the Windows 2016 server that it is hosted

  • Resolved wordpresssamurai

    (@wordpresssamurai)


    Just installed and configured a new WordPress site and made it into a multisite install on a Windows 2016 server running IIS. When trying to access the website by IP from any other machine on the network, the IP redirects to “localhost/wordpress” and does not resolve. I did not have this issue on a Windows 2008 server on the same network a few days ago.

    Tried turning off the firewall completely, I am able to ping the server, and the IIS page loads but not the WordPress page.

    What could be causing this and how can I enable access for people on the network to see the page without being redirected to “localhost”?

Viewing 6 replies - 1 through 6 (of 6 total)
  • the IP redirects to “localhost/wordpress” and does not resolve

    All machines have a “localhost” address.

    If you installed WordPress on the server (from the server) using “localhost” in the WordPress addresses, then it will only be available from the machine it was installed on. If you try to access it from the LAN you may be able to view the front page, however all other requests will try to resolve to the client you’re using, not the server where WordPress is located.

    I did not have this issue on a 2008 server and use the exact same information when setting up the server. I tried putting in the DNS name this time regardless and it seemed to solve the issue regardless. However the template now shows only text and no images now when accessing from another computer on the network.

    I think I had Just add define(‘FS_METHOD’,’direct’); added to wp-config.php which made it work on localhost. Not sure exactly what this does. I’m still trying to resolve the issues with only text showing up and no template.

    New issue: used DNS name and only the main page works, now all sub-pages redirect to localhost and does not load.

    Fixed Issue: Settings> General> Change localhost WordPress Address and Site Address to DNS names.

    Also changed IIS settings and security permissions.

    New Issue: I created a new site in my multisite installation and can’t access the new site dashboard. Is this another DNS issue?

    fix for web.config:

    <rule name=”WordPress Rule 4″ stopProcessing=”true”>
    <match url=”^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*)” ignoreCase=”false” />
    <action type=”Rewrite” url=”{R:2}” />
    </rule>
    <rule name=”WordPress Rule 5″ stopProcessing=”true”>
    <match url=”^([_0-9a-zA-Z-]+/)?([_0-9a-zA-Z-]+/)?(.*\.php)$” ignoreCase=”false” />
    <action type=”Rewrite” url=”{R:3}” />
    </rule>

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.