Support » Installing WordPress » can not upload image (adding new post)

  • Resolved fatsal

    (@fatsal)


    1.upgradet from 2.8.6
    2.new insatll of the 2.9
    same problem
    can not upload image (adding new post)
    but it works on editing a aviable post

Viewing 15 replies - 1 through 15 (of 25 total)
  • I dont know how and why but the problem solved it self.
    (I have refreshed the add new post page several times)

    for me not working. BUMP

    esmi

    (@esmi)

    Forum Moderator

    Try posting a new topic instead of posting on the end of a resolved topic.

    Just upgraded to 2.9.

    Both the flash and browser uploader achieve the same result. They say the .png is uploaded, but no thumbnail appears. No image appears in the post or page. But click “edit image” and there it is.

    Going to resort to FTP now to see if that’ll do it.

    Found that not only had the image not been uploaded to the path WP suggests, but that the directory 2009/12 had not even been created. My folder permissions have not changed, so suspect there’s a bug in 2.9.

    Created the folder and uploaded the image over FTP, and everything works.

    Wonder where the image that was shown when I clicked “edit image” (see my last comment above) is stored?

    Yes exactly the same problem. According to media manager it has uploaded but. there is no thumbnail and image on specified folder. When i upload image via ftp it works. Is it a bug on 2.9.1?

    thanks.

    Hi

    Its is not a bug in 2.9.1
    My media uploader is working fine.

    If you use gears for your WordPress Admin,
    Try deleting your gears and re-enabling it to see if it works.
    I had problems with getting scripts to work due to gears error.

    Hope it helps!

    Sorry! did not see this post has been resolved!

    If this post is resolved, perhaps someone could post the resolution?

    Or was the method of resolving the problem to “refresh the add new post page several times” until it works, maybe?

    Because that’s a crappy resolution.

    I am running a couple blogs with mu 2.9.2 and can’t upload images either.

    Whether it’s for a buddypress avatar, gravatar, or just adding an image to a post, it’s not working. I can upload from a url when that option is available but when I upload from my computer it just shows a blanks spot.

    Any suggestions?
    Thanks

    Having the same issue… seems to be rather pervasive with 2.9.2. My testing so far has included:
    1) Tested uploading with Firefox, IE 8, and Chrome
    2) Tested uploading with and without Google Gears
    3) Tested uploading after resetting Misc settings (upload path, etc)
    4) Tested uploading with both the flash and browser upload dialog
    5) Tested uploading after setting all wp-content perms to 777
    6) Tested uploading after re-upgrading to 2.9.2

    Always with the same result… I get the status bar for uploading, then crunching, then nothing. When I check with an FTP client the file is present, but no thumbnails were generated, nor does it appear in the Media Library.

    Needless to say this is a pain.

    UPDATE: Just set up a completely virgin 2.9.2 install and the upload worked. Arrrgh! Will now have to piece together my production site again using a virgin install, i.e. not an upgrade. Maybe that’s the key.

    Found the cause in my case… the Thesography EXIF Plugin.

    Hmmm

    Was everyone using the Thesography plugin or just jbourke?

    Was the problem with all images or only PNG files?
    What version of the plugin were you using?
    Did you have any other image related plugins active?
    How large were the files you were uploading?

    I wasn’t able to replicate the problem in my tests, but am implementing a few changes that will hopefully fix it — if the manipulation of the metadata upon import was interrupting the image processing.

    I’m having this trouble as well. Worked fine befor upgrading to 2.9.2.

    For me, the flash uploader is stuck at 0%, and then nothing happens. No image seems to be uploaded. The browser uploader just takes me to the media screen after “uploading”. No picture is in the database, BUT the image has been uploaded, and sits on the server.

    I have tried setting the “Full URL path to files”, but this just resets itself to empty after being saved. Any1?

    Clicking on the upload icon does nothing. No flash upload, no nothing.
    Some of the other icons and buttons have quit working as well. For example the Help button at the top right does nothing.

    For anyone having trouble with Thesography, please report the issues on my site. There was an update recently and have had no reports of errors.

    @bonka – Have you tried switching to the browser uploader instead of flash? Does it work?

    @tfindlay – Sounds like the javascript in your dashboard may be broken. Have you got javascript disabled? Have you tried using a different browser?

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘can not upload image (adding new post)’ is closed to new replies.