Support » Plugin: User Role Editor » Can not setting “upload file” to contributor and author

  • Hi

    I give role “contributor” to my friend and enable upload file to him. But when he upload the media, this notification appear

    File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.

    Then, i change his role to be “author”. I tried to make experiment with user role plugin but it resulted on appearing notification below when he upload image:

    File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini

    .

    Please help

    Thanks

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Vladimir Garagulia

    (@shinephp)

    Hi,

    When you grant ‘upload_files’ to a role URE just changed permissions included to this role, nothing more. If you get error message during upload process you have to find a reason in some other place.

    You need to check your WordPress installation. Can any other role ‘editor’ for example upload files? Try to deactivate all plugins. Can author upload files then?

    In my specific case, with same symptoms, problem was in third party plugin: WP User Avatar and not inside the User Role Editor. Increasing the upload limit inside the WP User Avatar solved the problem.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.