Support » Networking WordPress » Can not see Create a New Site link – on the My Sites page – Multisite User

  • I can’t see the link to “Create a New Site” in the “My Sites” page.

    I have no plugins activated.

    I do have New Blog Defaults activated in Super Admin.

    I have added this to my wp-config.php file:

    define(‘WP_ALLOW_MULTISITE’, true);

    define( ‘MULTISITE’, true );
    define( ‘SUBDOMAIN_INSTALL’, false );
    $base = ‘/’;
    define( ‘DOMAIN_CURRENT_SITE’, ‘businessmarketingreview.com’ );
    define( ‘PATH_CURRENT_SITE’, ‘/’ );
    define( ‘SITE_ID_CURRENT_SITE’, 1 );
    define( ‘BLOG_ID_CURRENT_SITE’, 1 );

    I have this in my .htaccess file:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    Any ideas… I couldn’t find where anyone had this problem before…

    I am using suPHP.

    Everything else seems to be working…

    I can create a new site, in the Admin site…

    But, I want individual users to create their own site.

    Jim

Viewing 8 replies - 1 through 8 (of 8 total)
  • Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Go check Super Admin -> Options – > registration.

    What do you have selected?

    User accounts may be registered

    It works at the signup link, when you first register…

    http://businessmarketingreview.com/wp-signup.php

    When logged in, can’t go to that link.

    Can’t see the link when user is logged in on the “My Sites” …. User can’t have multiply sites, from their 1 account…

    Did that make sense?

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    you’re not seeing the “my sites” link becasue you aren’t letting your users sign up and make sites. you’re only letting them have a username.

    pick the other one.

    Thank you…

    I looked at that and really thought it was checked… I knew that was the one I wanted marked… ‘Logged in users may register new sites.’

    I guess I should have taken a break and came back to it…

    Again, Thanks

    Actually… Now there isn’t the option to register, in the first place… That was why I ticked that other option, in the first place…

    What is the best way to have both and keep down the spam registers? (Which is why I didn’t ticked ‘Both sites and user accounts can be registered.’

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Tick ‘Both sites and user accounts can be registered.’ and install some anti spam measures.

    Thanks for the help!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Can not see Create a New Site link – on the My Sites page – Multisite User’ is closed to new replies.