Support » Plugins and Hacks » [Resolved] Can not publish Posts to Facebook

[Resolved] Can not publish Posts to Facebook

  • I have disabled all plugins but I am still getting the same error on posts: If you can see this, then there is some form of problem showing you the Facebook publishing buttons. This may be caused by a plugin conflict or some form of bad javascript on this page. Try reloading or disabling other plugins to find the source of the problem.

    What other troubleshooting is available?


Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Samuel Wood (Otto)


    WordPress.org Tech Dude

    Double check your Facebook Application, make sure you put the right URL in for your website.

    I believe the settings to be correct.
    site URL: http://www.sportsnapbackhats.com.
    here is a screen shot of settings http://www.sportsnapbackhats.com/wp-content/uploads/2012/11/simplepost.jpg

    @jcgoldy have you tried specifying the URLs without “www”?

    Anyway I have the same issue – Simple Facebook Connect keeps telling me that it can find the respective tokens:

    * No User or Access Token found. Try re-saving this page.
    * Application Access Token not found. Try re-saving this page.
    * Fan Page Access Token not found. Try re-saving this page.

    I have double checked all the values.

    More about this issue on WP SE: http://wordpress.stackexchange.com/questions/73311/simple-facebook-connect-access-tokens-not-found

    Furthermore I’m not sure what the plugin admin panel means by:

    In order for the SFC-Publish plugin to be able to publish your posts automatically, you must grant some “Extended Permissions” to the plugin.

    To do so, click this button. This will also cause the page to refresh, in order to save the results.

    I see no button to press.

    Extended permissions: I have activated the option “App on Facebook” in the FB App admin panel and set the URLs for “Canvas URL” and “Secure Canvas URL”.

    Or is it meant to set under “FB App Admin -> Settings -> Permissions” the value for “Default Activity Privacy:” to “public”?

    I don’t even want auto publishing. I just want to manual post when I add posts.

    Ok after re-installing the plugin it now works w/o any issues. My settings were correct all along! Something was corrupt about the install of the plugin.

    I would be happy with normal publishing too! You are lucky that it’s working for you!

    Deleting & Re-installing didn’t help for me either.

    Finally came one step further – the auth-button was not there because of FF 16, Chrome worked for this part. But still the page-token can’t be retrieved from Facebook, so no auto-publish to a page.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Can not publish Posts to Facebook’ is closed to new replies.