WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Can not override functions anymore?

[Resolved] Can not override functions anymore?

  • I was just trying to debug why one of the plugins I wrote quit functioning as of 2.5.1 (it worked on 2.3.3 at least, not sure about 2.5). When I checked, it appears that all 23 of the plugins that are supposed to be override-able already exist upon plugin activation now:

    http://codex.wordpress.org/Plugin_API#Functions_You_Can_Override

    Is this a bug? Was the ability to override functions in WP removed inadvertently in 2.5.1? Or is there a different process for doing so now? The file wp-includes/pluggable.php still exists, and those functions still appear to be contained within it, so it just looks like it is loading them before the plugins are loaded. This would mean that they were no longer pluggable, correct?

Viewing 1 replies (of 1 total)
  • I see this thread was marked resolved. How did you fix this? I am having the same problems.

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] Can not override functions anymore?’ is closed to new replies.