Support » Plugin: WordPress Importer » Can not import media-files – because they need to be items?

  • Like other users, I have problems to import media-files. The text is importing, but the media-files not, also I get no error-message. After trying a couple of solutions, maybe I have found the reason:

    I have exported posts from a post category. It seems that the Exporter from WordPress does not create the images as <item> like when you make an export of ALL things. I have tried to import a XML-file with all things (including the images as <item> in the XML) and it works without problems, the images are imported.

    Is there any developer who can verify that the media-files needs to be as <item> in the XML-file to import them?

    This is very stupid and in my eyes a huge bug, because if you want to export posts from a post category, then you want also import the images from these posts (e.g. when you delete all category entries on the old blog and transfer them to a new blog).

    Why the plugin does not use the <wp:base_blog_url> to identify the attachments in the <content:encoded> and import these files as new media-files to the posts? This is what I expect from the Importer-plugin. (Also: Why the Exporter does not create the media-files as <item> for this blog posts? Maybe optional?)

    • This topic was modified 2 years, 9 months ago by chriszim. Reason: Formatting code
  • The topic ‘Can not import media-files – because they need to be items?’ is closed to new replies.