Support » Plugin: User Role Editor » Can Not Edit Plugin

  • Hello,

    On my control panel, I see this on my edit page.. but nothing under it shows up. I can check these off and save but it will not show me the rest of the page. It came up once when I tried to signed in with another admin account.. when I logged out of that account and back in I could not see the page again.

    I see this…

    Show Administrator role at User Role Editor
    Show capabilities in the human readable form
    Show deprecated capabilities

    has a save button..

    but nothing under it on the page is loading..

    I can give you access to the site if you would like to see what it is doing for yourself.. I tried this on google chrome and explorer.


Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Vladimir Garagulia



    It is “the User Role Editor” Settings only and it is full list for the free version.
    “User Role Editor” itself is located under the “Users” menu. Please check there.


    Hi Viadimir,

    Thank you for the quick response. That was an easy fix. I see now that It comes up if I go under the users tab.

    It does work that way. However, Your plugin has a tab under both the “Settings” and under the “Users” tab. You may want to consider writing a fix for that, and remove it from coming up under the setting tab. When most users install a new plugin they first look for its features under the setting tab, if it is not showing up there they will start looking under the other feature tabs in the panel. The way your plugin comes up under the settings tab, I would think that it is suppose to be there and was corrupt. Most people would uninstall it thinking that it does not work properly. Your plugin is an awesome feature, and something as simple as this could make people not realize that and uninstall it.

    I am planning to do a review of your plugin at and it will get a positive review, however that would be a negative point about the plugin. I just wanted to give you some feedback because I really like your product.

    – Jeffrey

    Plugin Author Vladimir Garagulia


    Hi Jeffrey,

    Thanks for the feedback. Just look on this from this point:
    Under WordPress “Settings” menu you see the “settings” of the User Role Editor. Under WordPress “Users” you see “User Role Editor” main functionality.

    Do you think, it will be useful to add the text hint under the User Role Editor settings page with the link to the main User Role Editor module?

    It is possible that I move both menu items into separate 1st level “User Role Editor” menu at one of the future versions.


    I think that’s a good idea. I thought there was a problem with your plugin because at times the features came up under the setting tab also and then it did not. That made it seem like there was an issue. works great when I go under the users tab. Love your plugin though.

    Do you have any plans to make it also block buddypress posting in the future? That would be awesome. I mean so that you can block people from posting in the activity stream, members pages and on other buddypress pages. In case publishers wanted to make someone a true “Read Only” member. I love how your plugin can block wordpress core features.. wish you had one that did the same for buddypress. : )

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can Not Edit Plugin’ is closed to new replies.