Support » Plugin: Comments - wpDiscuz » Can not edit comment

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support gVectors Support

    (@gvectorssupport)

    Thank you Vy Spirit,

    As far as I see you’ve done customization, therefore, we couldn’t guess what’s gone wrong on your website.

    I recommend comparing with wpDiscuz source code it’ll help you to debug this issue.

    Hi,
    I just customize the class.WpdiscuzWalker.php and I think that doesn’t take away this feature.
    By the way, my website also does not save the name and email address for the next comment. What should I do?

    Update: I installed wpdiscuz on localhost with the same theme on my site, and I still can not edit the comment.

    • This reply was modified 1 year, 4 months ago by Trieu Vy.

    I updated wpDiscuz to version 5.1.5 and the edit comment feature was working properly.
    But when I reload the page, the Edit Comment button disappears.

    Plugin Support gVectors Support

    (@gvectorssupport)

    Hi @zztalano1zz,

    For further support please rename the class.WpdiscuzWalker.php file that you customized and check again.

    Hi @gvectorssupport,

    I’ve renamed the class.WpdiscuzWalker.php file in the child-theme that I’m using but the edit button still disappears after I reload the page.

    I tried deactivating my plugin cache as LiteSpeed Cache and it works perfectly stable even when I reload the page.

    I think wpDiscuz is not optimized for Litespeed Cache. The information (such as the name, email address, website) that the user entered in the comment form is not saved when they reload the site.

    • This reply was modified 1 year, 4 months ago by Trieu Vy.
    • This reply was modified 1 year, 4 months ago by Trieu Vy.
    Plugin Support gVectors Support

    (@gvectorssupport)

    @zztalano1zz,

    Please try to exclude wpdiscuz.js file from LiteSpeed Cache plugin settings and check again:

    This article explains how to exclude files:

    https://blog.litespeedtech.com/2018/01/31/troubleshooting-lscache-optimization/

    Hi @gvectorssupport,
    Thanks for your suggestion but it still does not help solve this problem.
    I also tried exiting the file /wp-content/plugins/wpdiscuz/assets/third-party/wpdcookiejs/customcookie.js but it still not working.

    • This reply was modified 1 year, 4 months ago by Trieu Vy.
    Plugin Support gVectors Support

    (@gvectorssupport)

    Hi @zztalano1zz,

    The Litespeed Cache plugin unsets comment’s cookies from global cookie array ($_COOKIE). Please contact Litespeed Cache plugin support.

    I’m sorry, but this cannot be fixed by wpDiscuz side.

    All right!
    However, you have fixed the main bug in this article.

    Thanks for the support!

    Hi @gvectorssupport,

    We unset cookie when generating the page in https://github.com/litespeedtech/lscache_wp/blob/master/litespeed-cache/inc/vary.class.php#L158 to prevent caching and serving current commenter’s info to other visitors.

    Is that possible that you hook to comments_array earlier or use JS to achieve your target?

    Thanks,
    Hai

    Hi @hailite,
    I’m really sorry but we can’t do this change. wpDiscuz has lots of dependencies on current code and hooks we use, it’ll require a large number of core changes. I’m sorry but we can’t do such changes yet.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Can not edit comment’ is closed to new replies.