Support » Plugin: Mailgun for WordPress » Can not disable “Mailgun is almost ready”

  • Hi, I set the Mailgun Env vars using wp-config.php and I add a define( ‘MAILGUN_REGION’, ‘us’); constant. But I still see the Warning in the top of backend section. “Mailgun is almost ready. With the latest update, Mailgun now supports multiple regions! …”

    I try to close using the X, but when I reload the page it shows again.
    Any advice to remove the warning?
    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • Came here to post this too. The warning cannot be dismissed even after adding all constants to wp-config.php.

    @mailgun any update on this? Any hack I can set under wp-congif.php to turn off the warning? thanks

    • This reply was modified 9 months, 1 week ago by  nico0012.

    The newest update fixed it for me. I have a multi-site install and they have returned the normal settings page in the WP dashboard which also removed the persistent admin notice.

    @bensibley Hi, thanks for the update. I get the 1.6.1 version installed and still get the warning message. Thanks

    • This reply was modified 9 months, 1 week ago by  nico0012.
    kyleschmitt

    (@kyleschmitt)

    I’m having this issue as well on multisite. Latest version and settings configured in wp-config, still getting the warning.

    If anyone else finds a solution I’m all ears!

    I found a way to fix this! Seems if you use: global VAR: MAILGUN_APIKEY in wp-config.php, after in the warning code section logic, this not works: $this->get_option(‘apiKey’);

    So, under [plugin_dir]/includes/admin.php , under admin_notices() function.
    I add:
    $apiKey = (defined(‘MAILGUN_APIKEY’) && MAILGUN_APIKEY) ? MAILGUN_APIKEY : $this->get_option(‘apiKey’);

    And I change:

    if ((!$apiKey && $this->get_option(‘useAPI’) === ‘1’) …

    • This reply was modified 8 months, 3 weeks ago by  nico0012.
    • This reply was modified 8 months, 3 weeks ago by  nico0012.

    If you update to 1.7, there’s no longer a settings page for multisite, you need to put the creds into wp-config – but the warning goes away!

    Example:

    
    // Mailgun
    define('MAILGUN_REGION', 'us');
    define('MAILGUN_USEAPI', true);
    define('MAILGUN_APIKEY', 'YOUR_KEY');
    define('MAILGUN_DOMAIN', 'yourdomain.com');
    define('MAILGUN_FROM_NAME', 'Your site name');
    define('MAILGUN_FROM_ADDRESS', 'no-reply@yourdomain.com');
    define('MAILGUN_SECURE', '1');
    define('MAILGUN_SECTYPE', 'ssl');
    
Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.