Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » can not connect to my sites

  • Resolved fhom61

    (@fhom61)


    500 status code for “POST /sites/158507507/publicize-connections/new”
    is one of the error messages I get when trying to connect my sites to jetpack publicize also get this message

    Debug
    XML-RPC is not responding correctly ( 409 )

    host site says xml is on and correct says need to check with Jetpack since it worked before updates

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support bruceallen

    (@bruceallen)

    Happiness Engineer

    Hi @fhom61

    I ran some tests on your site, and it seems that although your domain has a valid SSL certificate, it is still possible for one to access your site via HTTP. In fact, your visitors and search engines can use either HTTP or HTTPS to access your site.

    This is an issue for search engines, since it often causes confusion and duplicate content, but it is also an issue for your site’s communication with WordPress.com, as our system does not know whether it should connect to your site via one or the other address.

    To solve this issue, I would recommend that you change your site’s URL to HTTPS (you can do so under Settings > General in your dashboard), and then ask your host for help redirecting all traffic from HTTP to HTTPS. You can also use a plugin such as Really Simple SSL to do this for you.

    If your host is unable to help with that, you can follow the instructions here to do so:
    https://www.wpbeginner.com/wp-tutorials/how-to-add-ssl-and-https-in-wordpress/

    Once that’s done, try to reconnect your site to WordPress.com once again; that should solve your issue.

    I have the same 409 error in Jetback debug with the site https://www.gemsofwisdomconsulting.com/
    That site is already using HTTPS and Really Simple SSL. I’ve already disconnected and reconnected Jetpack and that went well, but WordPress.com says the site cannot be accessed.
    Site Health says the Wpcom test fails and recommends reconnecting, but as noted, that doesn’t help even though reconnection seems successful.
    https://www.gemsofwisdomconsulting.com/web/xmlrpc.php responds just fine.

    replying so I can turn notifications on.

    More info:
    Jetpack, for the most part seems to be fine. I found the issue when I was putting up a new post. When I tried to publish I got an alert saying I needed to reconnect to LinkedIn, and when I clicked on the alert to try to reconnect, all I got was a blank screen. So I went to WP.com and saw “The site cannot be accessed”.

    Thread Starter fhom61

    (@fhom61)

    Still have this issue. Contacted hosting site they checked everything and all is working. they said contact Jetpack and see if there was new setting that they needed

    wish this could be resolved soon

    Plugin Contributor Stef

    (@erania-pinnera)

    @rcharbonxx could you please start your own thread, as per the Forum Welcome?
    https://wordpress.org/support/plugin/jetpack#new-post
     
    Thank you!

    Plugin Contributor Stef

    (@erania-pinnera)

    Hi @fhom61, thanks for the follow-up!

    I did some more tests and I While your site is publicly accessible, we cannot access your site’s XML-RPC file for Jetpack:

    https://www.h3creations.net/xmlrpc.php?for=jetpack

    The 406 Not acceptable error indicates that something is still off with your servers and the way they connect with Jetpack.

    We’re aware of a recent conflict we’ve been seeing between mod_security and Jetpack on sites that are hosted with EIG hosts. We are working directly with the hosts to get to the bottom of the problem/ We hope to circle back soon to let you know when that issue has been resolved so we can determine if that is enough to get everything back up and working or if we’ll need to take other steps as well.

    I’d recommend reporting this to your host to report that your site is experiencing this issue.

    Sorry I can’t be more helpful at this stage on this.

    Plugin Support Mark Zakariya

    (@mzakariya)

    Hey there, @rcharbonxx!

    Thank you for patiently waiting while we continued to work with your hosting provider on this.

    It looks like they’ve fixed the connection issues, and Jetpack and its features should work as expected.

    However, it looks like your site is currently inaccessible, as it’s responding with a PHP error. This might be caused by an incompatible plugin, a failed plugin update, or a server configuration issue.

    If you were not already aware of this, please contact your hosting provider for additional guidance. They have access to error logs on their servers, and should be able to quickly identify and correct the cause of this error.

    Please let us know if Jetpack continues to misbehave after you’ve had a chance to address the PHP errors. We’re always happy to help! 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.