Support » Fixing WordPress » Can not click on the few Menu Items

  • The menu links in the main menu under the logo which have sub-menu items are not working. Other menus without sub-menus are Okay, though. How could I solve the problem?

    I tried to use page as well as categories in the custom menu area in the dashboard but none is working. When I click on the top menu which has a sub-menu underneath, the URL just shows a # mark. Any solutions to the p[roblem?

    The URL is

    Thanks and regards,


Viewing 3 replies - 1 through 3 (of 3 total)
  • Are you using WordPress’s built in menu system to build your menu. The main link that contains submenu’s is linking to # because that’s in their link, just #. If you’re using WordPress’s menu system, switch out the top level of those links with the actual link to where you want them to go. If it is a menu system built in to the theme you’re using, that’s another story. The theme may have a filter that is filtering the menu and replacing the top level links with the #.

    I am using the WordPress’s built in menu system. In fact, I tried to give the actual link to where I wanted the menu items to go But had no luck

    In that case it is most likely that the theme you are using, in order to get those mouseover flips, is using a filter to filter the menus and replaces the url. That filter would need to be hacked or you could ask the theme’s developers.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Can not click on the few Menu Items’ is closed to new replies.