Support » Fixing WordPress » Can not change options

  • I tried to change my options page and it won’t let me save changes it says:

    Access forbidden!

    You don’t have permission to access the requested object. It is either read-protected or not readable by the server.

    If you think this is a server error, please contact the webmaster.
    Error 403
    Thu Sep 27 17:21:33 2007

    I tried to change all access to 777 that didn’t work and then I read in a post here to change the directories to 755 and the files to 644. Still nothing! This is driving me crazy, does anyone have a solution?

    I am very new so keep your answers simple, sorrry!

    Julie Anne

Viewing 7 replies - 1 through 7 (of 7 total)
  • 777 is full permissions so if that didn’t work i don’t think its chmod perms.

    I’m guessing you don’t get errors when posting? Seems to be an established site (nice theme by the way) so what changed?

    Most likely a mod_security problem.
    Create a .htaccess in your wp-admin folder and add this to the file

    <IfModule mod_security.c>
    SecFilterEngine Off

    Then try.

    I get no other errors and didn’t change anything. I just decided that I want a link to all my blog posts on my site. Like “Our Blog” Now, I have a static first page.

    I tried to create a .htaccess page with the given code, but then I could not even get into my admin area. I do not see an existing .htaccess file anywhere so I created one with just the code given. Is there something more I should do to create a .htaccess file.

    Sorry for the amature questions!


    Check your server logs at about the time you try to access your admin and report the errors back.

    I have reported to them. I am really stumped! I began messing about today and realized I can change and update everything in the admin EXCEPT in the Options/Reading section, which of course is the only place I need to make a change.

    This is why people like me should not mess with this #$%%!

    So, I got antsy and thought why not just upgrade to 2.3 maybe there is something corrupt. So I did a back up on my database manually hopefully I did it correctly. I even installed a backup plugin and used it. Then I upgraded my wordpress. While the files where transferring I got this error that it could not copy image folder in the wp-admin folder. It got to the point where I just took all the files hide them and copied all the new ones on with the old wp-content.

    Now, my site is truly dead. all this for an added feature in the sidebar called “Our Blog” Tinkering should be a crime for people with no aptitude for programing!

    If anyone has any kind words I could use them now!


    To say this is resolved is not very helpful to others who may have this problem. My site is working! Do not ask me how, exactly. What happened in the end was I was sitting staring at the error message in some language I will probably never understand and gave up. I closed the browser window, but there was still a browser window hidden that popped up, which still had the admin panel from the options I was trying to change. I felt my site was permanently down and what the heck I pressed on view site. Still an error message! Back button! Then I pressed on my profile for some reason and it said “This site is not yet updated do you want to update?” YES! And up popped my site 🙂

    So, thank you to who ever made that work!


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Can not change options’ is closed to new replies.