Support » Fixing WordPress » Can not access website after changing the siteurl and home entries of wp_options

Viewing 14 replies - 1 through 14 (of 14 total)
  • Hi, it looks like you set the URL to be HTTPS but your site/CloudFlare is misconfigured to support SSL. What CloudFlare SSL option are you using? Do you have an SSL certificate installed on the server?

    Hi @wurpe,
    Thank you for your quick response.

    SSL
    Encrypt communication to and from your website using SSL.
    It may take up to 24 hours after the site becomes active on Cloudflare for new certificates to issue.
    Universal SSL Status Active Certificate

    These are the settings I am using.

    Sorry, I am newbie to all of this, but ask a lot of questions, in case I get annoying.

    Hi, are you using Flexible, Full, or Full (strict) SSL? Please try disabling CloudFlare proxy (CDN) for the time being so your site does not show that error.

    Hi!

    Thank you so much.
    I turned it off, it started working but does not load properly in the Flexible.

    The site is up but I am not able to access the wordpress admin page, neither through caod.orh.au/wp-admin or the google cloud which is basically “external IP/wp-admin”.

    If you can help with that, that’ll be really appreciated.

    Thanks.

    Hi, it seems you still have flexible SSL enabled which is causing an infinite loop redirect. Do you have an SSL certificate installed on your site? I’m linking a guide on how to set up CloudFlare Flexible SSL with WordPress but first you need to disable Flexible SSL so that you can access your WP admin.

    Hey mate!

    Thank you for being so responsive.

    First I tried tot turn off the SSL and it didn’t work. Website loads but the I tried disabling the cloudflare, so I paused the service altogether and still can not access the admin.

    Regards,
    AK

    Hello, you’ll need to change your URL back to HTTP (from HTTPS) by going in phpMyAdmin -> change siteurl and home in wp_options.

    Hi,

    I am not sure how to access the table and/or phpMyAdmin.

    I have been trying to find for a list of steps to access the table so I am not quiet sure how to get to that.

    And because I am still not able to access wp-admin, so I can not go into the site and directly change it from there.

    I found this link https://cloud.google.com/sql/docs/mysql/admin-tools#workbench on stackoverflow, and tried using it with workbench but that’s not working for me as well, for some reason.

    If you are aware of any resources that can help in this case, that’ll be great.

    Thanks.

    Hello, in that case, it would be easiest to hard code the site URL which can be done by adding the following 2 lines with your domain into wp-config.php:

    define('WP_HOME','http://example.com');
    define('WP_SITEURL','http://example.com');

    Hello,

    I have been trying to find the wp-config.php but can not.

    I am using WordPress-click to deploy on Google cloud and not bitnami. So there is no file director. I used ftp to ssh google cloud but could not find wordpress directories in that.

    https://console.cloud.google.com/marketplace/details/click-to-deploy-images/wordpress?_ga=2.234516572.-331145666.1535930662

    Could you please help with that?

    Thanks for all your help.

    • This reply was modified 1 year, 2 months ago by  aaykay.

    Hi, if you’re using FTP you can search for the file name. I’m not sure where GCP installs WordPress. I would try looking in /var/www/ and checking for a folder with the name of your domain or public_html.

    Hi there!

    I tried that but nothing really worked. There is no folder containing the file structure of the website, which is very weird.

    If you can redirect me to somewhere I can get some help on this, that’ll be great.

    Thanks for your help.

    Hello, are you able to try accessing your web server through sftp? I believe that with GCP when you access with FTP you are going to the home directory. Unfortunately, I’m unable to help with GCP too much and you should try contacting Google regarding this, sorry.

    Hi, actually, you may have better luck accessing your web server via SSH and editing the files that way. Files can be edited through SSH using the vi command: vi <filename>. With GCP you will need to use sudo su in order to log in as the root user.

    To move from directory to directory use the cd command: cd <directory> and to view the files in the directory use the ls command: ls.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Can not access website after changing the siteurl and home entries of wp_options’ is closed to new replies.