Support » Fixing WordPress » can no longer add an image

  • I’ve just started using wordpress, set up a site and all was well, wrote posts and added images without any problems.

    I then upgraded to v. 2.8.2.

    I then added a post, went to add an image but each time it fails to upload the image. It whirs as though it is uploading it and shows then image name but not the image. I tried adding it using the Browser Uploader and the Flash Uploader. I also tried to upload it directly through the media > add new.

    Nothing has changed on my server, and this domain is set to unlimited space.

    I have the same set up on other domains and they work ok.

    Please help, I am pulling my hair out and I have people screaming at me as the site is for a club.


Viewing 3 replies - 1 through 3 (of 3 total)
  • Having the same trouble!

    I was having this problem too.
    Make sure your permissions for the designated folder are set to 755.

    I went into Settings/Misc and unchecked the box for “Organize my uploads into month- and year-based folders”.

    But at the same time I added a .htaccess folder to wp-admin with the code below. Now I can upload images but the do not appear on the initial post page. I’m not sure which action worked but it did. So try one and then the other and test after each idea.

    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    <Limit PUT DELETE>
    order deny,allow
    deny from all

    # BEGIN WordPress
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off

    # END WordPress
    AuthName drmomonline
    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

    Well, I have managed to solve my problem, don’t know if it is the same as others here. I found that somehow the directory where the media is uploaded to had changed with wordpress/ being added. So a new directory had been made and all the files I had been trying to upload were there :O

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘can no longer add an image’ is closed to new replies.