WordPress.org

Forums

Can I setup WordPress.org on my own web server? (12 posts)

  1. evienalife
    Member
    Posted 6 years ago #

    Hi all,

    I managed to setup my own web server with a dynamic IP address and installed WordPress on it. It works fine on the server itself.

    The problem is, when I want to access my WordPress from another PC, it goes to http://localhost/wordpress of that PC and it gives this error "Oops! This link appears broken. HTTP 404 - File not found".

    How do I solve this problem?

    Thanks in advance.

  2. MichaelH
    Member
    Posted 6 years ago #

    Find your servername or server IP Address. In my case the IP address of the machine running the server is 192.168.1.157 so change your WordPress address URL and Blog address URL values to http://192.168.1.157/wordpress.

  3. itdaddy1
    Member
    Posted 6 years ago #

    MichalH

    you seem like the wordpress man can you help me.

    Okay the url place where you are talking about this is what happened

    I first had htt://localhost/wordpress in both spots on my admin console settings andthen i couldnot get internet access so I change both values to http://ccnp.itdaddy.net which is my FQDN for public access. great i get my blog via internet but I am locked out of
    my admin conosle remotely? wp-admin.phy console will not take my
    admin and password at all anymore what happend and how can i access both my wp admin console to manage and edit my blog on the road
    and access my blog on the road. The whole reason for my blog is public acces by anyone and remote maanagemnet of it? and where do i put the email/smtp relay server name in my blog setup. I host my own blog at home on my webserver and I have my own exhange server wherein the blog do i edit the server name and do i need authentication? or can i setup my server to relay the email to my exhange server? thanks

  4. evienalife
    Member
    Posted 6 years ago #

    Hi MichaelH,

    Thanks a lot for your reply.

    I've changed my WordPress address (URL) and Blog address (URL) to http://192.168.0.117/wordpress but it still doesn't work.

    When I type in the URL in another PC, it gives an error, "This webpage is not available. The webpage at http://192.168.0.117/wordpress. might be temporarily down or it may have moved permanently to a new web address".

    Even when I click on your URL, it gives me the same error "webpage is not available".

    Any idea why?

    Thanks.

  5. evienalife
    Member
    Posted 6 years ago #

    Hi itdaddy1,

    Nice blog. How did you get the FQDN name? Do you have to buy the DNS domain name or is it free?

    Thanks.

  6. MichaelH
    Member
    Posted 6 years ago #

    Note: if necessary you may need this if you need to edit the Blog and WordPress addresses:
    http://www.tamba2.org.uk/wordpress/site-url/

    Not sure what the problem is as I'm not having that problem on a XAMPP hosted internal site. Can you ping that server IP address from the other PC?

  7. evienalife
    Member
    Posted 6 years ago #

    Hi MichaelH,

    Thanks for the weblink.

    I can ping the internal server IP address from another PC, no problem.

    I'll follow the steps from the website and see how it goes.

    Thanks again. :-)

    -elaine

  8. itdaddy1
    Member
    Posted 6 years ago #

    evienalife

    this is what i do; i also have my own exchange owa server
    at mail.itdaddy.net

    i use godaddy to register my domain name of itdaddy.net
    then i use dyndns.com to be my dns provider. I pay for both
    maybe 100.00 a year for

    fqdn and ssl certs (2) godaddy.com and my registrar itdaddy.net name
    dns service dyndns.com

    dyndns give you a free program that resides on you LAN that pumps
    your pubic ip as it changes to their dns servers a fake static but effective dns service

    i have some issues with admin conole but bit by bit ;)

  9. itdaddy1
    Member
    Posted 6 years ago #

    evienalife

    dude what dns provider areyou using do you have your PC
    that is accessingthis site to your ISP dNS
    try adding your gateway Ip address of yoru internal LAN
    that is your firewall address say you use a linksys router that
    is 192.168.1.1 add that in the second DNS name in your TCP/IP
    settings try that let me know how it works

  10. itdaddy1
    Member
    Posted 6 years ago #

    evienalife

    hey bud

    i am hosting my own blog on my own home server but it is looking more and more i might have it hosted for me by hostmonster.com
    they host everything and have all the right accesd DNS and security
    and such; it is alot of work to get it going and keepingthe infrastructure going i am looking into public hosting i dont have time to do it all but wanted get some hands on but need to get on with my blog and my life ;O)
    I am a ciso guy not a webmaster ;)

  11. evienalife
    Member
    Posted 6 years ago #

    Hi itdaddy1,

    Oh, I see... you have your own web server, which is hosted on a paid web server, right?

    As for me, I setup my own PC and use it as a server, instead of paying for someone else's web server. I know my IP address is dynamic but the internal wireless IP address has been set to static. I also have a free dyndns DNS name @ http://somenamehere.blogdns.com

    When I ping this URL address from my web server, it is fine. No data packet is lost. When I ping the URL from another PC in my wireless network, it is also fine, not data lost but it took a longer time, ~57ms.

    But when this URL is ping from another PC outside of my local wireless LAN network, there is no reply. Hmmmph... any idea why??

    Thanks in advance.

    -elaine

  12. Bert1983
    Member
    Posted 6 years ago #

    192.168.x.x usually indicates an IP behind a router. Be sure to forward whatever port you are using to 192.168.0.117 in your router's settings and then go to http://www.whatismyip.com from the server to see your real IP. This is the number that wordpress wants for your wordpress address. This is also the number you should type in from your friends computer to view your website. I hope this helps.

    ~Bert

Topic Closed

This topic has been closed to new replies.

About this Topic