Support » Requests and Feedback » Can I make editor not strip non-breaking spaces

  • I’m trying to upload poems in my blog and they require the occasional non-breaking space ( ) tag to be correctly formatted. Both the Visual Rich Editor and the other default version that come with WordPress strip out these tags, which seems like a bug.

    QA: Edit a post using VRE – click the ‘html’ button to edit the html and add a few non-breaking-space tags – click ‘update’ on the html editor – see your lovely post in the main editing window with non-breaking-spaces – hit “save” – the spaces all disappear. Go back to the editor and they’re gone.

    Any ideas or do I have to get a plugin to allow me to put in non-breaking spaces? If so do you know of one I can use?

    Thanks!

Viewing 1 replies (of 1 total)
  • No idea about a plugin option, but you simply CANNOT do this with a wysiwyg as provided in wp. The wysiwyg strips code. I don’t know why it was thought this was a good idea, but that’s what it does.   is code. So it gets stripped.

    Disable the wysiwyg.

Viewing 1 replies (of 1 total)
  • The topic ‘Can I make editor not strip non-breaking spaces’ is closed to new replies.