WordPress.org

Forums

Drop Shadow Boxes
[resolved] Can I decrease padding inside the dropshadowbox? (3 posts)

  1. FoothillsInno
    Member
    Posted 2 years ago #

    I'm trying to display a table within a dropshadow box but whenever I add the HTML an unacceptably large amount of whitespace / padding is added around the table, especially at the top and bottom. It's substantially more than if you insert flat text. It has nothing to do with the cellpadding and cellspacing parameters of the table - this spacing is outside of the table area. Is there some way to eliminate this extra padding?

    http://wordpress.org/extend/plugins/drop-shadow-boxes/

  2. stevehenty
    Member
    Plugin Author

    Posted 2 years ago #

    There are a few things that can be causing this.

    First, the Drop Shadow Boxes plugin adds 10px padding to the box. I intend to make this configurable but for now, you can remove it by adding this to your styles.css file in your theme folder:
    .dropshadowboxes-drop-shadow{
    padding:0px!important;
    }

    Second, themes sometimes add margins to tables so you may want to check that out.

    These two causes you can do something about relatively easily. Although if you're comfortable editing css and html you may want to implement the shadows manually yourself rather than using this plugin.

    The third cause however is a bit more tricky. WordPress automatically adds line breaks here and there (
    tags) - sometimes even where there is no line break in the content editor. I suspect this is what's causing most of the space in your case. There's nothing the plugin can do to prevent WordPress from inserting these tags inside the box I'm afraid. There are some plugins (like this one) that will disable the auto-formatting for you completely but I'd advise caution here because they can cause unexpected side-effects.

    If you'd like to discuss this further, please get in touch via the support form.

  3. FoothillsInno
    Member
    Posted 2 years ago #

    Thanks for the analysis and the reply. I too suspect that this is being caused by spurious line breaks from the CMS as I've now seen this happen around tables and unordered lists. The spacing side to side remains the same but as soon as you add the HTML there's what looks like another line added above and below. I've figured out a workaround that doesn't require the use of the table in this particular case, so I'm good to go.

    Thanks again ...

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Drop Shadow Boxes
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic