Support » Your WordPress » Can I choose not to upgrade just yet?

Can I choose not to upgrade just yet?

  • I don’t want to upgrade just yet because I don’t have the time to troubleshoot if something goes wrong. In the meantime, I cannot seem to get into my Admin Panel. Is there a way I can keep updating my blog until I’m ready to upgrade?

    I get this error when I try to login to my admin:
    Fatal error: Call to undefined function: nocache_headers()

Viewing 4 replies - 1 through 4 (of 4 total)
  • It is a misconception thinking you have to upgrade to 2.1.

    On the contrary: DO NOT UPGRADE if you want to keep your sanity 😉
    The 2.0.x branch is and will be supported for years.

    So what do you think went wrong with my Admin? I haven’t touched or upgraded my blog in 2 weeks. It just gave me that error when I tried to login today.

    If you didn’t touch anything – did your host change anything?
    A hardware or software upgrade?
    Are all your files complete and in the proper place? (that error msg sounds like a corrupted file)

    I’ve talked to Dreamhost and the only response they gave me was “Upgrade to the new version to see if it would fix your problem.”

    They said they rolled out new updates for php 5.2 this weekend, but they don’t see how that could have messed up my site since the function nocache_headers is
    not a default PHP function but a custom function defined with wordpress.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can I choose not to upgrade just yet?’ is closed to new replies.
Skip to toolbar