WordPress.org

Forums

Can I choose not to upgrade just yet? (5 posts)

  1. ext212
    Member
    Posted 8 years ago #

    I don't want to upgrade just yet because I don't have the time to troubleshoot if something goes wrong. In the meantime, I cannot seem to get into my Admin Panel. Is there a way I can keep updating my blog until I'm ready to upgrade?

    I get this error when I try to login to my admin:
    Fatal error: Call to undefined function: nocache_headers()

  2. moshu
    Member
    Posted 8 years ago #

    It is a misconception thinking you have to upgrade to 2.1.

    On the contrary: DO NOT UPGRADE if you want to keep your sanity ;)
    The 2.0.x branch is and will be supported for years.

  3. ext212
    Member
    Posted 8 years ago #

    So what do you think went wrong with my Admin? I haven't touched or upgraded my blog in 2 weeks. It just gave me that error when I tried to login today.

  4. moshu
    Member
    Posted 8 years ago #

    If you didn't touch anything - did your host change anything?
    A hardware or software upgrade?
    Are all your files complete and in the proper place? (that error msg sounds like a corrupted file)

  5. ext212
    Member
    Posted 8 years ago #

    I've talked to Dreamhost and the only response they gave me was "Upgrade to the new version to see if it would fix your problem."

    They said they rolled out new updates for php 5.2 this weekend, but they don't see how that could have messed up my site since the function nocache_headers is
    not a default PHP function but a custom function defined with wordpress.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags