Support » Fixing WordPress » Can I change the URL path for my blog?

  • Resolved kenwinstoncaine


    Tried searching this and found 16,000-some posts. Read a dozen and none addressed this exact question, so, here goes:

    I installed WordPress on my server in a Word Press folder. That makes the URL basically:

    I would like to have it be: blog name/post name.

    How to do that at this point?

    Under options on the dashboard, it says, “”If you want your blog homepage to be different than the directory you installed WordPress in, enter that address here.” But that apparently is referring to something other than what I want to do. I tried putting my blogname there but then, when I tried calling up my blog with that path, I got a 404 error.

    Is there some really simple way to do this?


Viewing 10 replies - 1 through 10 (of 10 total)
  • Moderator James Huff


    You will need to change two values in Options/General, change the directory’s name, then update your permalinks in Options/Permalinks. See:


    I know this was pretty muched answered for the O.P. but I am currently using this Structure for the permalinks.


    It will display like such:

    As for the other question, I had a post some where on moving or changing the name of the Blog’s URL some where, but not going to worry about it lol, since macmanx gave ya that link lol. Just thought I’d share that permalink structure with ya…might help you or someone in the future. =)


    thanks, spencer p.

    may get back to you as i start playing with this (late today or early tomorrow, i think) if for some reason i’m not ‘getting’ it.


    I’m stuck.

    Thought I was following instructions to the ‘T.’

    Went into Adminstration/Options/General.

    Updated the WordPress address from to Bulletin

    Did same for blog address. Hit update. (Got a 404 error. Ignored it.)

    Went into Ws-FTP. Changed WordPress directory name to Mind-Body-Spirit Bulletin.

    Tried to log into blog using that path, to update the Permalinks info.

    Was able to input username/password, but when I hit submit, I got the message:
    Not Found
    The requested URL /Mind-Body-Spirit20Bulletin/wp-admin/options-general.php was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    What do I need to do now, please?

    Is the problem possibly that the name I gave the directory has a space in it? Should I have used a hyphen or underscore for that? And how do I get back in to the admin panel to do whatever fix is needed?


    Let me add that I checked, using FTP, the WP-Admin folder IS in the Mind-Body-Spirit Bulletin folder and that the options-general file IS in that folder.

    Not sure why it’s not finding it; why it’s not letting me log in.

    Moderator James Huff


    Most server configurations don’t like to have spaces as part of directory names. Try changing the directory name to “Mind-Body-Spirit-Bulletin“. You will need to manually change the two URL values with phpmyadmin. See:

    OK. Onto it macmanx. Thanks.

    Wow, you’re helpful! That did it, of course.

    GREAT tutorials you’ve referred me to.


    Moderator James Huff


    Glad to be of service. ^_^

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Can I change the URL path for my blog?’ is closed to new replies.