Support » Reviews » Can break other plugins – use with extreme care!

Can break other plugins – use with extreme care!

  • I was going to give this 2 stars, but when I saw the ‘Works’ attribute popup, I had to go with 1 because this plugin could really frack your site depending on what other plugins you had installed. It did ‘work’ for me, but in the narrowest possible definition.

    One example is this: http://wordpress.org/plugins/visual-editor-custom-buttons/. If you have Post Type Switcher enabled, any time you update a custom button it gets converted to a Post and there’s no way to get it back. I’m not sure what would happen with bulk editing, but if it’s the same then you could do massive amounts of damage to your site without noticing.

    It would be a very useful plugin, but it needs to be able to gather a list of all existing custom post types and make sure it’s set to use each post’s current type by default. Either that or just have the default setting be no action. Having the post type updated every time you update a post is asking for trouble.

  • The topic ‘Can break other plugins – use with extreme care!’ is closed to new replies.