WordPress.org

Support

Support » How-To and Troubleshooting » can activate/deactivate but can't delete plugin

can activate/deactivate but can't delete plugin

  • MouseClicks
    Member

    @mouseclicks

    Hello there,

    I have 2 plugins on a site that I need to delete. One is Broken Link Checker the other is WP Security Scan. I can activate and deactivate both of them but when I click the delete link, nothing happens – it acts like a dead link.

    I don’t want to just delete from ftp because then the tables for these plugins will remain — I need a clean delete. I’ve changed ftp permissions to 777 on each of them but that didn’t work. I’ve tried renaming them via ftp, that didn’t work.

    Any suggestions?
    Thanks,
    Deb

Viewing 1 replies (of 1 total)
  • MouseClicks
    Member

    @mouseclicks

    UPDATE: For anyone else experiencing this — looks like I fixed it.

    I ftp’d in, renamed the plugins *folder* to pluginsBAK momentarily. Clicked in the admin over to the plugins page where it then showed all plugins had been disabled. I then went back to the ftp, renamed pluginsBAK back to plugins, went back to the plugins page in the admin, refreshed the page and reactivated the plugins *excluding* the two mentioned above that I wanted gone. I was then able to delete them and all seems well.

    Hope this helps someone else.

Viewing 1 replies (of 1 total)
  • The topic ‘can activate/deactivate but can't delete plugin’ is closed to new replies.