[resolved] Can’t select database Error (3 posts)

  1. Maxell
    Posted 7 years ago #

    Hi. I Uploaded my site on an ftp host which i have used several times and it have worked great.

    But when i have uploaded the folder wordpress and all of its content and then tries to start up the install.php on the browser it gives me errors.

      The Error

    <quote>Can’t select database

    We were able to connect to the database server (which means your username and password is okay) but not able to select the maxell.ma.funpic.org database.

    * Are you sure it exists?
    * Does the user maxell have permission to use the maxell.ma.funpic.org/blogg/ database?
    * On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?

    If you don't know how to setup a database you should contact your host. If all else fails you may find help at the WordPress Support Forums.</quote>

      And this is the options
    // ** MySQL settings ** //
    define('DB_NAME', 'maxell.ma.funpic.org');    // The name of the database
    define('DB_USER', 'maxell');     // Your MySQL username
    define('DB_PASSWORD', 'XXXXXX'); // ...and password
    define('DB_HOST', 'localhost');    // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    // Change SECRET_KEY to a unique phrase.  You won't have to remember it later,
    // so make it long and complicated.  You can visit http://api.wordpress.org/secret-key/1.0/
    // to get a secret key generated for you, or just make something up.
    define('SECRET_KEY', 'ellinormattias'); // Change this to a unique phrase.
    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix  = 'wp_';   // Only numbers, letters, and underscores please!
    // Change this to localize WordPress.  A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    /* That's all, stop editing! Happy blogging. */
    define('ABSPATH', dirname(__FILE__).'/');

    Thankful for any help!


  2. MichaelH
    Posted 7 years ago #

    This looks suspect:

    define('DB_NAME', 'maxell.ma.funpic.org'); // The name of the database

    Also, check with your host about the DB_HOST value.

  3. Maxell
    Posted 7 years ago #

    I searched on their forum about the the database name and found what to do. Thanks for the help.

Topic Closed

This topic has been closed to new replies.

About this Topic