WordPress.org

Forums

[resolved] Can’t change permalinks to anything but default. (2 posts)

  1. willkanoff
    Member
    Posted 3 years ago #

    I realize that this question has been posted many times but still I couldn’t find a working solution.
    I am building a site with WP 3.3.1 on Wamp server 2.2.
    I’ve successfully created three custom post types and build index pages for each one. With the permalinks set to default everything is working just fine. The problem though is that when I try to change them to anything else I still get the Home page but instead of any other pages I get this:

    Not Found
    The requested URL /pianovids/piano-video-2/ was not found on this server.

    And this is what’s in .htaccess file

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    As soon as I change permalinks to the default everything is back to normal.
    I’ve been trying figure this on out for two days but the problem’s still there.

    Please, could anybody tell me what am I doing wrong?
    Thank you!

  2. willkanoff
    Member
    Posted 3 years ago #

    Resolved it!
    Needed to enable mod_rewrite in httpd.conf.
    Damn, I’m goooood ;-)))

Topic Closed

This topic has been closed to new replies.

About this Topic