Support » Plugin: Claudio Sanches - Correios for WooCommerce » Campo estado não está preenchendo automaticamente

  • Salve Claudio, tudo certo?

    Na recente atualização do Woocommerce o campo “estado” (billing_state) deixou de ser auto-preenchido depois de colocar o CEP. A cidade, a rua continuam sendo preenchidos normalmentes.

    Já tentei:
    – Desativar todos os plugins;
    – Mudar de tema;

    Log:
    08-31-2020 @ 10:27:10 – Fetching address for “85501020” on Correios Webservices…
    08-31-2020 @ 10:27:13 – Address for “85501020” found successfully: stdClass Object
    (
    [postcode] => 85501020
    [address] => Rua Goianases
    [city] => Pato Branco
    [neighborhood] => Centro
    [state] => PR
    [last_query] => 2020-08-31 10:27:13
    )

Viewing 15 replies - 1 through 15 (of 29 total)
  • Boa Noite,
    Tenho o mesmo problema, em várias lojas, depois de fazer a atualização do Woocommerce.

    Alguma ajuda?
    Muito obrigado!

    • This reply was modified 1 year, 2 months ago by mrimpact.

    Boa noite. Estou com o mesmo problema.

    O Campo Estado está tendo que ser preenchido manualmente.

    Alguém tem uma ideia de solução?

    Aqui também, inclusive alguns clientes não então conseguindo finalizar o pagamento pois preenchem manualmente e logo após volta a ficar em branco novamente, não são todos só alguns.

    Aqui o mesmo problema, uso tema Astra

    @mixbee, percebi isso fazendo alguns testes aqui. Na verdade sempre que tem alguma informação errada ou ausente na Checkout, quando a pessoa for tentar refazer o Estado fica em branco de novo, mas quando colocamos manualmente e o restante das informações estão corretas. O checkout acontece normalmente sem erros.

    Mesma coisa aqui também!

    Estou com o mesmo problema, tentei de tudo aqui para resolver, inclusive o valor do frete calculado no carrinho, some após o cliente ir para página de pagamento. Se desativar o autopreenchimento, ai só aparece o estado após digitar o CEP. Cláudio ajuda ai por favor…

    Pessoal uma solução momentânea que encontrei aqui é desativar o cálculo do frete no carrinho, assim quando o cliente digitar o CEP no checkout o estado aparece e calcula o frete. Segue o caminho: Woocommerce > Configuração > Entrega > Opções de Entrega > Desmarque a opção “Ativar a calculadora de frete na página de carrinho”

    Voltem para a versão do WordPress 5.4.2. Foi o que resolveu aqui. Usei o plugin WP Downgrade e resolveu em segundos. Vamos aguardar uma atualização do Claudio que certamente ocorrerá.

    Encontrei um pleativo no GIT proposto pelo rfBastos: Troque o codigo do arquivo woocommerce-correios/assets/js/frontend/autofill-address.min.js por esse abaixo

    /*!
    
    Claudio Sanches - Correios for WooCommerce: Autofill Brazilian 2016.
    Autofill address with postcodes.
    Version: 3.0.0
    */
    jQuery(function(a){var b={init:function(){this.autofill("billing",!0),a(document.body).on("blur","#billing_postcode",function(){b.autofill("billing")}),a(document.body).on("blur","#shipping_postcode",function(){b.autofill("shipping")})},block:function(){a("form.checkout, form#order_review").addClass("processing").block({message:null,overlayCSS:{background:"#fff",opacity:.6}})},unblock:function(){a("form.checkout, form#order_review").removeClass("processing").unblock()},autofill:function(c,d){if(d=d||!1,a("#"+c+"_postcode").length){var e=a("#"+c+"_postcode").val().replace(".","").replace("-",""),f=a("#"+c+"_country").val(),g=a("#"+c+"_address_1").val(),h="yes"===WCCorreiosAutofillAddressParams.force||0===g.length;""!==e&&8===e.length&&"BR"===f&&h&&(b.block(),a.ajax({type:"GET",url:WCCorreiosAutofillAddressParams.url+"&postcode="+e,dataType:"json",contentType:"application/json",success:function(a){if(a.success&&(b.fillFields(c,a.data),d)){var e="billing"===c?"shipping":"billing";b.fillFields(e,a.data)}b.unblock()}}))}},fillFields:function(b,c){a("#"+b+"_address_1").val(c.address).change(),a("#"+b+"_neighborhood").length?a("#"+b+"_neighborhood").val(c.neighborhood).change():a("#"+b+"_address_2").val(c.neighborhood).change(),a("#"+b+"_city").val(c.city).change(),a("#"+b+"_state").val( c.state ).change()}};b.init()});
    • This reply was modified 1 year, 2 months ago by Marcelo Melo.

    @3dingbat alterei porém não funcionou 🙁

    @mixbee a melhor alternativa que deu certo aqui pra mim foi a dica do @laserstore
    Voltei para a versão do WordPress 5.4.2. Foi o que resolveu aqui. Usei o plugin WP Downgrade e resolveu em segundos. Vamos aguardar uma atualização do Claudio que certamente ocorrerá.

    @3dingbat Aqui funcionou sem precisar de downgrade, obrigado!

    @3dingbat aqui não tinha funcionado, mas eu não tinha atualizado a versão do woocommerce. Depois que fiz isso ele funcionou! Obrigado!!

    • This reply was modified 1 year, 2 months ago by laserstore.

    Aqui corrigiu atualizando o Woocommerce apenas. Abs

    @dogvibe obrigado pela dica do Rfbastos, para mim resolveu instalando o plugin Enable jQuery Migrate Helper, pois o problema foi que o wordpress removeu o jmigrate pois só plugins com códigos bem antigos ainda usam!!!

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Campo estado não está preenchendo automaticamente’ is closed to new replies.