Support » Plugin: WP Easy Post Mailer » Campaign queued, starting in 46 years

  • Resolved martinrtaylor

    (@martinrtaylor)


    I’ve just added a new post which has been queued for mailing, and the Campaigns tab shows this as queued. But under Progress it says “Starting in 46 years”. Still stuck there several hours later, not surprisingly.

    It has worked just fine for all previous posts. I tried deleting the post and then creating it again, but I got the same result.

    https://wordpress.org/plugins/wp-mailer/

Viewing 15 replies - 1 through 15 (of 15 total)
  • Added another post, same thing happened. Starting in 46 years.

    I’m having the same issue. martinrtaylor, did you ever get an answer from them?

    Follow up — I tried this out on another site — and the plugin seems to work properly. It just has extended the cue from 15 minutes to 46 years for the site I mainly use it on. New posts have the same result.

    No I didn’t get an answer – it would have been posted in this thread. I’m going to try uninstalling and re-installing the plug in to see if this helps.

    can I ask the number of posts you’ve successfully sent this way? — I’m wondering if it has a limit — my site started doing this after 25 posts.

    Well I seem to have found a fix that works. I just de-activated and re-activated the plugin. I didn’t lose any posts or any subscribers in doing this process, and it magically reset all the queued posts to 15 minutes.

    If you want to try this, go to Plugins -> Installed Plugins on the main menu, and then under WP Easy Post Mailer, click on the Deactivate link. Then click on the Activate link.

    Hope this works for you!

    My site started doing it after only 6 posts. So I don’t think it’s some kind of limit on the free version. Suspect it’s just a bug.

    That worked!! Thanks so much! Hopefully this will fix it for awhile 🙂

    Hello,

    I am sorry that I have not been in touch, work has been quite busy.

    When the plugin is activated it tries to create a wordpress cron that runs every 15 minutes and checks for any posts that need to be emailed out. For some reason in very rare setups it creates the cron to start in 46 years. The page that says when the posts will be sent simply requests the date/time of when the cron is due to run next.

    The reason I have not fixed this is because I have not been able to replicate the issue myself, I have asked a few people if they can give me access to their wordpress to debug the issue but they have never got back to me.

    My “guess” is that another plugin is interfering with this plugin and causing the cron to change.

    Richard

    I recently had this problem (queued campaigns not sending after 65 campaigns). Deactivating/Reactivating the plugin did not help. However, based on Richard’s suspicion that it may be a plugin conflict, I disabled all other plugins and this solved the problem. The plugins I disabled were Aksimet Anti-Spam, NextGen Gallery, and WP Crontrol. If I narrow it down further I’ll post more information.

    Plugin Author Richard Leishman

    (@webfwd)

    I would be interested to speak with you jdeanwilson if you have time as I would like to combat this issue once and for all.

    Happy to help. Is there a way to take this offline?

    Plugin Author Richard Leishman

    (@webfwd)

    Thank you.

    I am on Skype most days (mr dot leishman) and available on email (richard at webfwd.co.uk)

    Plugin Author Richard Leishman

    (@webfwd)

    Thanks to jdeanwilson’s help, we have found the cause of this issue. When the plugin is stating that the campaign is starting in the far distant future, this is because someone or another plugin has enabled DISABLE_WP_CRON but the webmaster has not correctly setup the manual cronjob in their hosting control panel.

    If DISABLE_WP_CRON is set to true then this disables WordPress’s CRON feature to be able to run commands on specific dates at specific times without user intervention. Without this feature, WP Easy Post mailing becomes pretty useless.

    More Information: https://code.tutsplus.com/articles/insights-into-wp-cron-an-introduction-to-scheduling-tasks-in-wordpress–wp-23119

    Thank you, Richard, for your time and help. I’ve applied the fix you described above and the problem appears to be solved. Couldn’t ask for better support. Cheers, jdeanwilson

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Campaign queued, starting in 46 years’ is closed to new replies.