Support » Plugin: WordProof Timestamp » Callback is Stuck in post list

  • Resolved Per Olsson

    (@styrketrappan)


    Hi,

    When I edit a post and save the timestamping seem to work fine, however if I go into Posts and browse through that list and click the button “Request new callback” I get “Something went wrong.” immediately. I can go into posts with that message though, save the post and get the timestamp so I hope that it has nothing to do with firewalls.

    I have looked with Chrome console and do not receive any errors in that.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I am seeing something similar here, curious how this can be resolved.

    • This reply was modified 4 months, 2 weeks ago by dunrie.
    Plugin Author WordProof

    (@wordproof)

    Hi Per and dunrie,

    In the latest update, we added a new REST route to receive the callbacks send by WordProof. To try if this solves your issue, please update the plugin to version 2.9. After updating, you need to change the webhook url in my.wordproof.com.

    1. Go to my.wordproof.com/content
    2. Hover over the three dots next to the WordPress icon
    3. Click ‘Edit source’
    4. Click on ‘Advanced setup’
    5. For the webhook url, insert https://$yoursite.$tld/wp-json/wordproof-timestamp/v1/posts and click save

    You can check if this solves your problem by clicking the ‘Retry webhook’ button in the WordPress backend.

    If this doesn’t solve the issue, please sent us a message at support@wordproof.com.

    Thread Starter Per Olsson

    (@styrketrappan)

    Worked as a charm on a post with the button “Timestamp this page” however the other issue seem to be there still. When I click the “Retry webhook” I still get “Something went wrong”.

    In chrome console I get this error on the “Retry webhook”:
    Uncaught (in promise) TypeError: Cannot read property ‘createNotice’ of null
    at x.addEditorNotice (Timestamp.js:197)
    at Timestamp.js:185

    Dont know if this error message helps

    Plugin Author WordProof

    (@wordproof)

    Hi Per,

    Is it possible that you timestamped those items with a different account? If you can send a mail to support@wordproof.com, I’ll have some extra tools available to look at the problem!

    @dunrie, let me know if the updated plugin solves your issue as well!

    Thread Starter Per Olsson

    (@styrketrappan)

    I sent a mail to support@wordproof.com with more details, thanks!

    Plugin Author WordProof

    (@wordproof)

    Hey Per,

    I can’t see any mail from you, can you try to send it again? You can reach me directly via jelle@wordproof.com. I will close this topic for now while I wait for your email so I keep things organized, but we’ll get to the bottom of this:)

    We have rolled out several updates in the past week, so trying the setup (and timestamps) again might help as well!

    Jelle | WordProof

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.