Support » Plugin: WooCommerce Correios - Cálculo de Frete na Página do Produto » call_user_func_array() expects parameter 1 to be a valid callback, cannot access

  • Resolved niteroiwebsites

    (@niteroiwebsites)


    Olá, boa tarde!

    Inicialmente devo parabenizá-lo pela grande iniciativa desse plugin.

    Depois da instalação do plugin esse erro apareceu no painel:

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, cannot access private method Woocommerce_Correios_Calculo_De_Frete_Na_Pagina_Do_Produto::check_woocommerce() in /home/conta/public_html/wp-includes/class-wp-hook.php on line 298

    O plugin está ativo, aparece na área de navegação, porém, não calcula o frete. No console de erros do chrome aparece a seguinte mensagem :

    Uncaught TypeError: Cannot read property ‘Valor’ of undefined

Viewing 14 replies - 1 through 14 (of 14 total)
  • joaoclini

    (@joaoclini)

    Boa tarde. Mesmo problema aqui.

    Eudis

    (@eudis)

    Boa noite!
    Nossa você teve a manha de criar uma coisa bastante útil…

    Porém como relatou o amigo acima… acho que precisa de um pequeno ajuste ai…
    veja o que ocorre aqui no meu..

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, cannot access private method Woocommerce_Correios_Calculo_De_Frete_Na_Pagina_Do_Produto::check_woocommerce() in /home/…/www/wp-includes/class-wp-hook.php on line 286.

    Se puder dar uma luz agradecemos

    • This reply was modified 1 month ago by  Eudis.
    Plugin Author lucasbustamante

    (@lucasbustamante)

    E aí galera, vou dar uma olhada e lanço o fix amanhã… Valeu!

    Plugin Author lucasbustamante

    (@lucasbustamante)

    Resolvido agora no update 1.3.7, valeu galera!

    niteroiwebsites

    (@niteroiwebsites)

    Oi Lucas, boa tarde!

    Obrigado pela interação e o ajuste no plugin!

    baixei a atualização, conforme indicado, porém, qualquer movimentação que eu faça no painel do WordPress aparece uma tela em branco com a seguinte mensagem: “Antes de usar este plugin, configure o CEP da sua loja em WooCommerce -> Configurações.”

    Bom dia!
    Valeu pelo ajuste ,porém… no meu estou com a versão 1.3.8 e nada aconteceu… não aparece na minha página e tb nao da erros… o que sera que pode ser?

    Ativei o plugin na primeira vez e ele estava apresentando aquele Warning, depois que vc evoluiu ai agora não acontece nada na minha página.

    Att

    Plugin Author lucasbustamante

    (@lucasbustamante)

    @eudis, cria um novo tópico aqui pra gente tratar disso?

    niteroiwebsites

    (@niteroiwebsites)

    @lucasbustamante

    Chegou a ver essa minha interação?

    “baixei a atualização, conforme indicado, porém, qualquer movimentação que eu faça no painel do WordPress aparece uma tela em branco com a seguinte mensagem: “Antes de usar este plugin, configure o CEP da sua loja em WooCommerce -> Configurações.”

    Desde já, te agradeço bastante! Abs

    Plugin Author lucasbustamante

    (@lucasbustamante)

    @niteroiwebsites peço desculpas por isso, vou lançar um fix em breve, enquanto isso peço que desative o plugin, consegue fazer isso?

    niteroiwebsites

    (@niteroiwebsites)

    @lucasbustamante

    Obrigado pela resposta. Só fiz a interação porque fiquei com receio de que o meu comentário tivesse se perdido.

    O plugin está desativado, só ativo mesmo quando vou fazer testes.

    Fico no aguardo. Sem pressa.

    Desde já, muito obrigado.

    Plugin Author lucasbustamante

    (@lucasbustamante)

    @niteroiwebsites acabei de lançar a versão 1.3.9 que resolve esse problema, valeu!

    niteroiwebsites

    (@niteroiwebsites)

    @lucasbustamante

    baixei a nova versão. Agora aparece outro erro na ativação:

    Parse error: syntax error, unexpected ‘[‘ in /home/brugger/public_html/wp-content/plugins/woo-correios-calculo-de-frete-na-pagina-do-produto/includes/class-woocommerce-correios-calculo-de-frete-na-pagina-do-produto.php on line 267

    Plugin Author lucasbustamante

    (@lucasbustamante)

    Ah sim, peço perdão, usei a sintaxe de array que requer PHP 7. Vou atualizar aqui pra suportar PHP 5~

    Plugin Author lucasbustamante

    (@lucasbustamante)

    @niteroiwebsites Gentileza testar novamente com a versão 1.4.0

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.