Support » Plugin: Hustle - Email Marketing, Lead Generation, Optins, Popups » “Call User Func” error after installing latest version

  • Resolved paul_lenk

    (@paul_lenk)


    Hi there,

    I updated the plugin to the latest version last night and I started getting the follower error in all pages of my website:

    Warning: call_user_func() expects parameter 1 to be a valid callback, first array member is not a valid class name or object in /xx/xxxx/xxxx/lyxplanet/wp-content/plugins/wordpress-popup/popover.php on line 646

    I had to deactivate the plugin for now. What can I do to fix this issue? Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi there @paul_link. Sorry to hear you are getting an error with the update. The developers are going to work on compatibility with PHP 5.3 on the next update as some of the providers do not support the ::instance() function.

    In the meantime, you can try upgrading the version of PHP on your server as this seems to be limited to older versions of PHP.

    Thank you for letting us know.

    @jdailey, thank you so much for this awesome plugin 🙂
    I encounter the same problem (When submitting the form getting “Something went wrong” error (logs display the error above).
    Would love to help, if needed.

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hello,

    Can you tell me which email provider you’re using when this message is displayed?

    Cheers,
    Predrag

    Tried in test mode and hubspot. Same error.
    Also, I think this may be related to https://wordpress.org/support/topic/something-went-wrong-please-try-again-5/ ?
    Cheers

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @szadok,

    Thread you linked is happening when no provider is selected so these two are not related.

    However this might be related to your Hubspot account, please go to your Hubspot account settings and make sure that API is enabled.

    If you’re still having issues with this after that please start new thread per forum rules and we will investigate this further.

    Cheers,
    Predrag

    Thread Starter paul_lenk

    (@paul_lenk)

    Hi there,

    I have no email service selected. I chose to “Save emails to local list”. Is that why I’m getting the “Something went wrong” error? Do I have to select an email provider?

    Thanks!

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @paul_lenk,

    Yes, “Save emails to local list” does still require to have any email provider selected in order to complete subscription properly.

    Cheers,
    Predrag

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘“Call User Func” error after installing latest version’ is closed to new replies.