WordPress.org

Support

Support » How-To and Troubleshooting » Call to undefined function: xml_parser_create()

Call to undefined function: xml_parser_create()

  • Using ecto to post to my site, I get the error “Fatal error: Call to undefined function: xml_parser_create() in /geekdreams.com/htdocs/wp-includes/class-IXR.php on line 146”.

    This happened after upgrading my server to PHP5. But xml_parser_create() is supported in this version, so I don’t understand why I’m getting the error. Help?

Viewing 7 replies - 1 through 7 (of 7 total)
  • my understanding is there’s a libxml2 library somewhere that you’re likely missing from your PHP installation…

    -d

    geekdreams: I had this exact same problem, I’m guessing that your host is DreamHost. If so they are running PHP as CGI if you upgraded to PHP 5. This means that you cannot run fopen() which is vital to a lot of things in WordPress such as reading in RSS feeds.

    davidchait: Your CG-FeedReader has the same problem, since it uses fopen() to get the RSS feeds it does not work for anyone trying to use PHP 5 on DreamHost. From what I’ve read you need to use the curl method instead of the fopen() method.
    Also david, your CG-FeedReader causes validation problems, you cannot have an <h2> tag within a <span> tag. I had to go into cg-feedread.php myself to fix the problem.

    1. xml_parser_create the way I use it is in-memory only, not reading from a file. So even if fopen() is turned off, shouldn’t be a problem. Still needs the libxml2 installation though.

    2. Actually, CG-FeedRead hasn’t had a problem with any of the fopen stuff for a long time now, as it uses sockets directly. FR works fine on DreamHost right now, as http://www.realtechnews.com/blog/rtnews.php is FR processing on DH.

    3. Grab the 1.5.2 release (out today, whenever my site comes back!), and the spans should now be divs… I think… If not, let me know.

    -d

    If they are using DreamHost as I am, I would like them to upgrade to PHP 5 to see if CG-FeedReader still works because I did the upgrade to PHP 5 and then all of a sudden none of my FR stuff worked, as well as the WP Dashboard. I went into my DreamHost Panel and change my service back down to the previous version of PHP and then everything worked fine again, so if its not the PHP 5 then I don’t understand why all of my FR and Dashboard stuff stopped working just after it was upgraded to PHP 5.

    I had exactly the same problem. Solved by re-emerging php with the ‘xml’ flag set (in /etc/make.conf)

    Odd, I just re-emerge php 4.4.2 with xml set (in /etc/portage/package.use – where Gentoo prefers php flags to be set now), and I still get the error.

    I have no idea what your talking about and this is damn annoying. If this is going to be an ongoing problem I would perfer to go back to the previous version.

    Can someone pass along the fix in English please?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Call to undefined function: xml_parser_create()’ is closed to new replies.