Support » Plugin: amr ical events lists » Call to undefined function wp_date()

  • Hello,

    i have wordpress 4.9.19 (last 4.9 version) and i have this error :

    PHP Fatal error: Uncaught Error: Call to undefined function wp_date() in /appli/www/wordpress/wp-content/plugins/amr-ical-events-list/includes/amr-pluggable.php:1621\nStack trace:\n#0 /appli/www/wordpress/wp-content/plugins/amr-ical-events-list/includes/amr-pluggable.php(1685): amr_wp_format_date('c', Object(DateTime), false)\n#1 /appli/www/wordpress/wp-content/plugins/amr-ical-events-list/includes/amr-pluggable.php(1457): amr_format_date('c', Object(DateTime))\n#2 /appli/www/wordpress/wp-content/plugins/amr-ical-events-list/includes/amr-ical-groupings.php(52): amr_format_value(Object(DateTime), 'EventDate', Array, '', '')\n#3 /appli/www/wordpress/wp-content/plugins/amr-ical-events-list/includes/amr-ical-groupings.php(112): amr_list_event_subset(Array, Array, Array, Array)\n#4 /appli/www/wordpress/wp-content/plugins/amr-ical-events-list/includes/amr-pluggable.php(1274): amr_list_events_in_groupings(Array, '', Array, false, Array)\n#5 /appli/www/. in /appli/www/wordpress/wp-content/plugins/amr-ical-events-list/includes/amr-pluggable.php on line 1621

    wp_date was introduced in 5.3.O : https://developer.wordpress.org/reference/functions/wp_date/

    Is it possible to fix this error for older version of WordPress ?

    Thanks,

    Anthony

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author anmari

    (@anmari)

    Hi Anthony,

    You could get someone to write a function wp_date and have it call the old function date_i18n in an appropriate way to achieve the same result.

    OR you could downgrade the amr-ical-events-plugin to an older version, which hopefully you have backed up somewhere.

    Generally it is best to keep things in sync and not to upgrade some areas without upgrading others. wp is now on 5.9. It is highly likely that you will start experiencing other similar problems with theme and other plugins if you upgrade them without upgrading wordpress itself.

    Thread Starter bibianthony

    (@bibianthony)

    Hi Anmari,

    thanks for you reply.

    Unfortunately i have no dev competence for writing this function 🙁 , please is it possible to give me the code to add to fix ?

    I understand you. Upgrade was done because it’s says the plugin is working fine on 2.8+ wordpress installation: https://fr.wordpress.org/plugins/amr-ical-events-list/ (100% compatibility with 4.9.x)

    Can you update the page compatibility for others users ?

    if you can’t give me code to fix, Wich version of plugin amr is full compatible with 4.9.x ?

    Thanks a lot,

    Anthony

    Plugin Author anmari

    (@anmari)

    Hi Anthony,
    yes compatibility will be updated, apologies for that. It was good when users were allowed to assist by confirming testing/works on various versions.

    Honestly the best way to handle this, is to upgrade your wordpress installation. By running an old version, you are exposed to known vulnerabilities
    https://patchstack.com/database/?search=&type=core

    The version of the plugin that goes back that far is no longer available, you’d have to get it from your backups.

    Sorry, I do not have the time or the inclination to write such code. The best approach is to keep wordpress up to date.

    Thread Starter bibianthony

    (@bibianthony)

    Hi Anmari,

    thanks for you reply and the update of compatibility page.

    Anthony

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.