Support » Fixing WordPress » Call to undefined function request_filesystem_credentials()

  • Resolved ozitsupport

    (@ozitsupport)


    Very weird issue here. Brand new installation, uploaded everything to the site root, go to the URL and get:

    Fatal error: Call to undefined function request_filesystem_credentials() in /home/ozitsupport/public_html/oncallgeek.com.au/wp-admin/includes/class-wp-upgrader-skins.php on line 47

    Anyone have any ideas?

    As a bit of background, this is an add on domain with its own root directory, hosted by GoDaddy (have a similar thing with another URL and never had an issue with that one).

    Any help much appreciated

Viewing 15 replies - 1 through 15 (of 15 total)
  • Most likely some files are missing or corrupted. This can happen on new installs. The solution is to download to your computer a set of WordPress 4.0.1 files, then access your site using FTP and delete and then upload fresh copies of directories “wp-includes” and “wp-admin”

    Hi Ross,

    Thanks for the speedy reply.

    This was was even after downloading 4.0.1 from wordpress.org and uploading all files via FTP. It hasn’t even started the install of WP yet

    It would be ideal if you could get a catalogue list of all the files with md5sum values, but this is difficult to do.

    The definition of this function is in file:
    wp-admin/includes/file.php
    Could you upload this files again.

    And that has sorted the issue!!!

    Thanks so much Ross!!!

    Could you mark this thread as resolved.

    Done. Tried to that after, too quickly it seems!

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Make sure you upload ALL the files again. If you didn’t upload one file properly somehow the first time, then it’s likely that others might be wrong too.

    Please, I have the same issue.

    When I click on any menu option on the admin dashboard, i get the following error:

    Fatal error: Call to undefined function request_filesystem_credentials() in /home1/testroot/public_html/testsite/wp-admin/includes/class-wp-upgrader-skins.php on line 75

    Even when I uploaded wp-admin/includes/file.php, I still got the same error.

    Right now, I cannot do anything on the dashboard.

    Please, kindly assist.

    Regards,

    Stardrive

    Hello,

    I have detected the pro version of a popular slider plugin to be the cause of the above strange and rare problem. I discovered this after deleting the plugin in my control panel of my web host.
    I have notified the plugin vendor.

    Best Regards,

    Stardrive

    Hi Stardrive,
    I think this may be the cause of my problem also, everything was working fine until I activated a slider last night and now i cant access my admin or site at all … please inform me if you are given a solution or can suggest another slider plugin i could try? I will try deleting that through c-panel now. Thankyou

    Hi amokdesign,

    The slider with the issue was Master Slider plugin pro version.
    The plugin author have fixed the issue and released an updated version of the plugin today. So, if you are using master slider pro, you can upgrade to the new version

    Regards,

    Stardrive

    Thankyou, it was included in my theme so i dont know if it was pro version or not, do you know how i could upgrade it if i cant access my admin panel? can i do it through c-panel? Thanks for your quick reply

    You can upgrade by using FTP to transfer Master Slider Pro plugin folder (masterslider) from your local computer to the plugin folder of your web host control panel.

    in my case , it was the popular MASTERSLIDER that caused my problem (screen of death) , i had to rename the plugin folder via FTP to deactivate it and my site is back again … tnx gyus for the help.

    The plugin author have resolved the screen of death issue. So, you can re-install or activate the plugin

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Call to undefined function request_filesystem_credentials()’ is closed to new replies.