WordPress.org

Support

Support » Installation » [Resolved] call to undefined function is_multisite after wordpress 3.0 upgrade

[Resolved] call to undefined function is_multisite after wordpress 3.0 upgrade

  • Whats up with that?

    I upgraded from 2.9.2 to 3.0 using the automated option from inside my WordPress admin section.

    As soon as it finished unpacking files, I got a blank screen.

    When I review my log files, all I see is:

    [Thu Jun 17 15:35:11 2010] [error] [client zz] PHP Fatal error:  Call to undefined function is_multisite() in /var/www/vhosts/mydomain/httpdocs/wp-includes/wp-db.php on line 505

    wtf?? It did not even prompt me for a database upgrade or anything.

    I then went and manually downloaded the wordpress 3.0 files and uploaded them myself overwriting the old files.. I still get blank pages everywhere.

    Cannot get to wp-admin.. cannot run wp-admin/upgrade.php or anything.

    What am I supposed to do now?

Viewing 15 replies - 1 through 15 (of 30 total)
  • I get the same error, after following the directions on the postings because that was what first appeared. “Fatal Error on Upgrade, Allowed memory size exhausted?” Tried changing back, no go, contacted server, they say it’s a wordpress 3.0 error in programming code. Help would really be appreciated since now there isn’t any access at all to our blog. Thanks

    Moderator Andrew Nacin

    @nacin

    Lead Developer

    The memory limit is:
    http://wordpress.org/support/topic/411365?replies=10#post-1556093

    For the undefined function error, please try a manual upgrade; it appears your automatic upgrade didn’t finish.

    Thanks, already tried the link above, and we use hughesnet which won’t allow that much bandwidth for our many blogs. Hate being hacked again due to new upgrade problems. bummer for us. but thanks again.

    Moderator Andrew Nacin

    @nacin

    Lead Developer

    It’s not a bandwidth thing, it simply increases the amount of memory PHP can use in the admin area. Most big PHP applications like WordPress need at least 32 MB, maybe 48 or 64 MB, in order to function. The more plugins, the more memory required. If you’re running a locale, that requires more memory. And during automatic upgrade, more memory is required.

    Hey Nacin (or whoever else is around)

    I’m having the same issue as serialboxhpc

    Tried auto-upgrade and it failed. Downloaded the zip and followed the steps for the manual install (deleted wp-admin and wp-includes and uploaded the new files via ftp. did not delete wp-content, but did copy over files with the new files in the zip) I checked the upload and the file number and size is the same in both the unzipped file and the server directory (84 files, 5 directories, 796,861 bytes on both sides for wp-admin; 88 files, 5 directories, 2,639,514 bytes on both sides for wp-includes)

    Fatal error: Call to undefined function: is_multisite() in /homepages/17/d280324655/htdocs/blog/wp-includes/wp-db.php on line 505

    Thanks,
    Kat

    Moderator Andrew Nacin

    @nacin

    Lead Developer

    We include functions.php (which holds is_multisite()) just before we include wp-db.php, which then uses is_multisite() on initialization.

    I’m not really sure what’s going on here then. Plugins get included after this point, the only thing that gets included before this is wp-content/advanced-cache.php if it exists.

    If there’s anything you’d like me to try or if you want to see copies of the code that was part of the download, please let me know and I’ll post it if you think that would be helpful to you guys.

    Thanks for responding so quickly.

    I’m also getting the is_multisite() problem, as well as Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘__return_zero’ was given in /home/hlaird/electronicshrug.net/wp-includes/plugin.php on line 166

    I’m wondering if it isn’t an issue with the fact that dreamhost did not previously allow for WordPress MU without purchasing a Private Server, and now that it’s integrates into 3.0, the hosts are getting angry.

    Mine’s 1and1 and the problem I had was between me being a bone-head and needing to fix something in my htaccess fille to play nice with 1and1.

    My bonehead problem – Nacin was right – it was an incomplete upload – I checked everything in wp-admin and wp-includes, but I neglected to check whether everything had correctly uploaded to /blog root. It hadn’t. Fixed that and bam! the fatal error problem went away and turned in to a 500 internal server error. A quick Google found me the fix for that in the .htaccess and now we’re up and running along.

    Thanks Nacin for your response. Hopefully my error will help someone else figure out where they need to check.

    Kat

    Moderator Andrew Nacin

    @nacin

    Lead Developer

    antonskey — __return_zero() is another function new in 3.0, and it is also in wp-includes/functions.php. Updating that file with one from a downloaded zip of 3.0 should fix it. To be safe, I’d do a complete manual upgrade of wp-admin and wp-includes. http://codex.wordpress.org/Upgrading_WordPress

    Kat, glad I could help.

    oooo dear .. these site are falling like skittles ..and it was all going so well. I installed WordPress today from DreamHost and it looked like a new version so I’m guessing this is 3.0. I only went to upgrade the themes and got the same error. Specifically ….

    Fatal error: Call to undefined function is_multisite() in /home/localeyes/transitionhaverfordwest.org.uk/wp-includes/wp-db.php on line 505

    Whats the definitive fix for this please in as simple language as you can make it.

    Thanks in advance

    ok .. I’m back up and running. I simply downloaded 3.0, unzipped and uploaded/overwrote JUST the files in the root dir, nothing else. Phew!

    ok .. I’m back up and running. I simply downloaded 3.0, unzipped and uploaded/overwrote JUST the files in the root dir, nothing else. Phew!

    I just did the exact same thing as above… fixed it and now it’s working fine!

    I spoke too soon… also had to: Keep your wp-content folder, remove wp-admin and wp-includes and replace them with what comes with a download of the WordPress 3.0 zip file.

    Any solution on this, I got the same error??

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘[Resolved] call to undefined function is_multisite after wordpress 3.0 upgrade’ is closed to new replies.