Support » Plugin: FeedWordPress » Call to a member function setting()

  • Resolved cms_


    Hi Charles,

    After upgrading to 2012.1212 today, we’re getting the occasional error when the spiders come crawling for /tag/sometag/feed/ URLs.

    2012/12/13 00:47:53 [error] 30914#0: *6683 FastCGI sent in stderr: “PHP message: PHP Fatal error: Call to a member function setting() on a non-object in /var/www/progblog/ on line 615” while reading response header from upstream, client:, server:, request: “GET /tag/breast-cancer/feed/ HTTP/1.1”, upstream: “fastcgi://unix:/tmp/php-fpm.sock:”, host: “”

    php5 5.3.19-1~dotdeb.0
    nginx-common 1.2.6-1~dotdeb.0

    Please let me know if any further information is required. Thanks again for your tireless efforts in helping disseminate information far and wide. – Chris

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author radgeek


    Thanks for the heads-up. I’ll take a look at this in the morning. Will post here if I need any further information.

    Plugin Author radgeek


    Hey there,

    Thanks again for this bug report! I believe that I have identified the source of the error. (It took a bit of chasing to figure out what’s going on, but it had to do with the handling of feeds that have been deactivated, but which still have posts from them archived in the wp_posts table.) It should be fixed in the current version of FWP on Github, and will be rolled into the incremental release that I’m putting out on Monday. Tentatively, unless I see it cropping up again, I’ll mark this resolved when the new version is released.

    Hope this helps.


    Plugin Author radgeek


    So, just wanted to let you know that the fix for this issue should be available in 2012.1218, released today (announcement here: , code available through WordPress plugin repository here: or at Github here: ). Let me know if this works for you; for the time being, I’ll mark this issue as resolved, if that’s alright.


    I am still seeing this in 2012.1218:

    “PHP Fatal error: Call to a member function setting() on a non-object in /var/www/html/planetdevops/wp-content/plugins/feedwordpress/feedwordpress.php on line 606”.

    Server is Nginx with FastCGI.

    WP is 3.5.1.



    Same error here with WP and the plugin updated.

    I updated the plugin yesterday and got the same error.

    fix: replace this on line #606
    if (!empty($source) && $source->setting(‘munge comments feed links’, ‘munge_comments_feed_links’, ‘yes’) != ‘no’) :

    if ($source->setting(‘munge comments feed links’, ‘munge_comments_feed_links’, ‘yes’) != ‘no’) :

    P.S. To the plugin author: please enable WP debugging while working on the plugin whenever possible. There are lots of notices that show up.



    I cannot thank you enough Svetoslav for this fix! I’ve been combing for a while trying to find the source of the error.

    This totally cut off the stream to my error log.

    Thanks Svetoslav.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Call to a member function setting()’ is closed to new replies.