Support » Plugin: ACF: Better Search » Call to a member function add_help_tab() on null in /wp-admin/network

  • Resolved Aubrey Portwood

    (@aubreypwd)


    When we network activate this plugin, or activate it on a site in multisite, this error is shown:

    Call to a member function add_help_tab() on null in /app/public/wp-admin/network/settings.php on line 24

    https://cloudup.com/cZMVPGqfbKK+?.diff

    Above is the patch we had to apply to get this to work, essentially only loading the settings class in normal admin, not network.

    Let me know if you want me to get a commit up for this.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    @mateuszgbiorczyk I’ve deleted your offer to login to your user’s site. I’m am 100% sure you mean well but please never ask for credentials on these forums.

    https://make.wordpress.org/support/handbook/forum-welcome/#the-bad-stuff

    Now for the why: The internet is a wonderful place full of very nice people and a few very bad ones. I’m sure everyone here is very nice however, by giving some ones keys to your house you are trusting they wont steal anything. Likewise the person who takes the keys is now responsible for the house FOREVER.

    If something was to go wrong, then you the author may well legally become liable for damages, which they would not normally have been as their software is provided without warranty.

    Please be aware that repeatedly asking for credentials will result in us asking you to repeatedly stop before escalating up to the plugins team.

    @jdembowski Did you get the right post? ¯\_(ツ)_/¯

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    Yes, I did. The one where the author replied with

    I need access to your environment to investigate. Give me access to the admin panel and FTP. Please contact me at…

    Which as explained above isn’t cool here.

    Plugin Author mateuszgbiorczyk

    (@mateuszgbiorczyk)

    Hi @aubreypwd,

    If you have the opportunity then try to fix it and let me know what you changed.

    I have created multisite and I don’t have problem with it. How can I simulate your problem?

    @jdembowski If you view this page https://wordpress.org/support/topic/call-to-a-member-function-add_help_tab-on-null-in-wp-adminnetwork/ you will see that @mateuszgbiorczyk hasn’t requested access to anything on this post.

    @mateuszgbiorczyk I have attached a patch above with a fix.

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    Off topic: Sorry, I was unclear, the author did exactly what I said. The difference is that I archived his post as I said at the top.

    You can’t see that post by the author but any moderator here can. Please stop insisting I missed the mark. I didn’t.

    Plugin Author mateuszgbiorczyk

    (@mateuszgbiorczyk)

    @aubreypwd Thank you very much for help. I added your change to the latest update.

    Can you add a review for my plugin? I will be very grateful!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.