WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] Calender Widget stops pages displaying For Feb (13 posts)

  1. cocopops67
    Member
    Posted 2 years ago #

    Calender has been working fine, nothing has changed. I cannot move forward and view after Jan 31st calender just stalls and nothing shows up on page just the url - no content. I can move backwards in time and it's fine. I can also use the search form to find the 1/2/2013 but not via the widget. I have used it previously to see other dates but all of a sudden nothing.

    http://wordpress.org/extend/plugins/calendar/

    P.S> By typing the URL in the browser it seems the whole of Feurary won't load http://www.whatsoncardiff.net/events/2013-03-01/ is ok but anything with 02 in such as http://www.whatsoncardiff.net/events/2013-02-01/
    is blank

    I have had to remove the calender widget from the site as it wont load with it

    http://wordpress.org/extend/plugins/events-manager/

  2. cocopops67
    Member
    Posted 2 years ago #

    Please ignore the reference to:
    http://wordpress.org/extend/plugins/calendar/

  3. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    I'm managing to see Feb events, e.g. with the link above i see the ones on Feb 01

  4. cocopops67
    Member
    Posted 2 years ago #

    Yes thats because I have removed the calender widget - if I put it back on the page does not load - on all browsers - on Chrome it gives a time out message. Maybe it's corrupt data - i have had a look at the data but all seems ok. you will now see on http://www.whatsoncardiff.net the calender is removed from the sidebars.

    I assume the calender loads with links of each event - is it possible a link is too long or corrupt or maybe too many events on one day?

    Is there a way I can remove the links of the events and just leave the date link so at least its clickable?

    Thanks

  5. agelonwl
    Member
    Posted 2 years ago #

    Hi,

    can you check if there's any javascript or jquery error using your browser error console; using chrome right click > Inspect Element > click Console then test it again ?

  6. cocopops67
    Member
    Posted 2 years ago #

    I cant inspect element as the page doesnt load at all when the calender is added

  7. agelonwl
    Member
    Posted 2 years ago #

    I see, another thing is try to turn-on WP_DEBUG or see your php logs to see if there's any other error.

    http://codex.wordpress.org/WP_DEBUG

  8. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    since you had so many events just on that one day, I'm guessing you may have a lot of events causing the calendar to take long to load and your script timed out.

    we're going to be making some performance tweaks for situations like yours to speed up the calendar loading

    one thing you may want to check is your php error logs, it may be your site just ran out of php memory, which can be increased (and it may be low to begin with)

  9. cocopops67
    Member
    Posted 2 years ago #

    error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 85 bytes) in /public_html/wp-includes/post.php on line 595
    [05-Feb-2013 13:57:02 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 82 bytes) in /wp-includes/wp-db.php on line 1545

  10. esmi
    Forum Moderator
    Posted 2 years ago #

    This is a site issue - not a plugin one. Try increasing the memory available to PHP.

  11. cocopops67
    Member
    Posted 2 years ago #

    Thankyou, I have contacted the host to find out if thats the problem. I really do not need the events listed on the calender - I will never use that feature, so is there a way of just having a blank calender that just links to the post dates - and nothing else?

  12. cocopops67
    Member
    Posted 2 years ago #

    Thanks for your help guys - it's now working - it was the server memory
    response from host

    Looking at the error given, this is exhausting 134MB of memory for the PHP scripting which setting a php.ini with 64MB would not have fixed.

    I have added a php.ini which allows php to use up to 256MB to process. Please could you try running the script again to see if the error still appears.

  13. agelonwl
    Member
    Posted 2 years ago #

    Seems to be working fine now.

    thank you for updating and sharing the problem/solution.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.