Support » Plugin: Fast Secure Contact Form » Calendar style problems with FSCF

  • Resolved Jose Luis de Lara

    (@josedelara)


    I am having style problems with this excellent form plugin.
    My actual page looks like having no style at all. I am using twenty eleven theme. The issue is with the calendar drop-down input menu that looks transparent and completely unaligned, creating a visual mess by mixing with the rest of the elements and labels in the form.
    I am not a guru on this, so please be patient with me.
    After reading some articles, I was able to perform a few changes in the ctf_epoch_styles.css file, but this only works when previewing the form.
    The actual worldpress page using the form looks fine except when trying to set a date on the form. No CSS changes are reflected in the actual page.
    What am I doing wrong?
    Your help is really appreciated.

    https://wordpress.org/plugins/si-contact-form/

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hi Jose Luis de Lara can you share your contact form URL.

    Thank you

    The problem is when clicking into check-in or check-out boxes.
    Styles are fine and responding according to the changes in the ctf_epoch_styles.css file when using the preview option of the plugin, but the actual page ( http://www.charminn.com/rates/reservation-request/ )is a different deal.
    Your help is really appreciated. Thanks a lot!

    Sometimes it is caused by css in your theme, try testing with a different theme to see if the problems goes away

    An insanely high z-index in your theme css can cause it
    z-index: 99999;

    Yes, changing the theme fixes this particular issue with the calendar pull down style. Thx Mike!! This is a progress, problem is the whole disign gets screwed.
    What would be correct z-index?

    I have tried with a z-index: 999 – No success!
    Could someone take a look at this problem, because changing the theme fixes the issue but is not an option at this time.
    I have tried with the original theme style, and the problem is still the same.
    There ia a significant customization task performed an the theme, that achieves what we wanted! That’s why changing the theme is not an option.
    Your help will be really appreciated.

    Have you been in contact with the theme developers about your issue?

    I have posted the problem at the theme support page for more than 2 weeks, but nobody has replied.
    Could someone give some orientation what to do? or where to look for? The Firebug extension does not give me information for this case, or I have not enough experience about how to troubleshoot this issue.
    Please help out!
    Thanks a lot!

    Hi, I was playing around a bit with your site.

    Test the following custom code.

    #epoch_popup1_4_calendar {
    background-color: blue;
    }

    For your second calendar test the following custom code.

    #epoch_popup1_5_calendar {
    background-color: blue;
    }

    Change the color to what ever you want. See if that works.

    Regards

    Hi, thanks a lot for your reply!!! I wish the guys from the theme would reply that fast!
    Q: Where exactly should I insert the code? in the style.css?
    I really appreciate your support! Thanks a lot!!!
    I believe the problem is not only about the background-color but the whole styles for the pop-up calendar.
    Definitely, this is a problem that involve the twentyeleven theme I am using; somehow it does not allow the plugin style to work.
    FYI:
    I have extracted htm code using firefox web developer tool in an effort to compare the code of 2 different themes using firebug. This is available at the site, as follows =>
    http://www.charminn.com/test.html <= this is the code using twentyeleven theme I am pursuing to fix.
    http://www.charminn.com/reservation-request-14.htm <= this is the code using twentyforteen theme, where the calendar style works well but not the rest
    You can see the difference in the calendar style of both pages by clicking at check-in.
    My skills to figured out this issue are limited, I though you may be able to find out the root cause of the problem.
    Anyways, again thanks a lot for your help!

    Hi Jose, there are some themes that allow you to add custom code yourself. If you theme does not have that option then try the following plugin. This plugin allows you to add custom CSS code without affecting your other plugins.

    If you install the plugin simply copy and paste the custom css code I mentioned above.

    In regards to the Twenty Eleven theme, that is an old style theme. I would start looking into one of the new default WordPress themes.

    New Themes To Consider:

    • Twenty Twelve
    • Twenty Thirteen
    • Twenty Fourteen
    • Twenty Fifteen

    Regards

    Thanks a lot for all your tips.
    The blue background color worked!
    I will try to rebuild the entire calendar pop-up styles in the custom’s style.
    Thanks again!

    Hi Jose, you can change the background color to what ever color you want. I simply used that color as an example.

    If your question has been answered can you mark this support thread as resolved.

    Thank you

    Thank you!

    FYI: I copy all plugin styles from ctf_epoch_styles.css file into customs styles and IT WORKS PERFECTLY!!!
    Therefore, the problem is: twenty-eleven theme does not allow the styles from this terrific FSCF plugin to work!
    Thanks!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Calendar style problems with FSCF’ is closed to new replies.