Support » Fixing WordPress » Calendar problem

  • the calendar on my index page shows up, but clicking on the link to a previous month doesn’t work. I assume that this has something to do with the way I set up my permalink structure, but I’m not sure how to fix it. I’ve found the get_calendar function in the template-functions-general.php file, but don’t know what to adjust to make this work. Does anyone know?

    Thanks in advance for your help. Here is my site: (click on Dec below the calendar to see the problem).

Viewing 7 replies - 1 through 7 (of 7 total)
  • have you modified the .htaccess for permlinks?

    I did that on mine and it works fine

    No, I don’t think I did. How do I do that? WP tells me that “Using the permalink structure value you currently have, /%year%-%monthnum%-%day%/%postname%, these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.”

    But, looking at the .htaccess file, I’m not sure what I’m supposed to change…

    thanks for the help.

    here’s my .htacess…what do I change?:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^category/(.*)/(feed|rdf|rss|rss2|atom)/?$ /wp-feed.php?category_name=$1&feed=$2 [QSA]
    RewriteRule ^category/?(.*) /index.php?category_name=$1 [QSA]
    RewriteRule ^author/(.*)/(feed|rdf|rss|rss2|atom)/?$ /wp-feed.php?author_name=$1&feed=$2 [QSA]
    RewriteRule ^author/?(.*) /index.php?author_name=$1 [QSA]
    RewriteRule ^([0-9]{4})-([0-9]{1,2})?-([0-9]{1,2})?/?([_0-9a-z-]+)?([0-9]+)?/?$ /index.php?year=$1&monthnum=$2&day=$3&name=$4&page=$5 [QSA]
    RewriteRule ^([0-9]{4})-([0-9]{1,2})?-([0-9]{1,2})/([_0-9a-z-]+)?/(feed|rdf|rss|rss2|atom)/?$ /wp-feed.php?year=$1&monthnum=$2&day=$3&name=$4&feed=$5 [QSA]
    RewriteRule ^([0-9]{4})-([0-9]{1,2})?-([0-9]{1,2})/([_0-9a-z-]+)?/trackback/?$ /wp-trackback.php?year=$1&monthnum=$2&day=$3&name=$4 [QSA]
    RewriteRule ^feed/?([_0-9a-z-]+)?/?$ /wp-feed.php?feed=$1 [QSA]
    RewriteRule ^comments/feed/?([_0-9a-z-]+)?/?$ /wp-feed.php?feed=$1&withcomments=1 [QSA]

    Moderator James Huff


    Volunteer Moderator 🚀

    You need to have at least /archives/%year%/%monthnum%/%day%/ in order for your calendar to function properly.

    sorry for the noob issues, but I’m still confused after following your link. When I tried putting /archives/%year%/%monthnum%/%day%/ into the first gray box on the options-permalink page, and then clicking “update permalink structure,” the links to my old posts no longer worked. Do I have to do that and then add a mod rewrite rule to the .htaccess file?

    Moderator James Huff


    Volunteer Moderator 🚀

    Yes, a text output should appear towards the bottom of the Options/Permalinks page after you create the permalinks. Add that to your .htaccess file. Just follow the instructions at Options/Permalinks and/or . Just read everything and you’ll be fine. And, since you’ll have to do this over again, use the following as your permalink (it removes the possibility of destroying your site because you posted twice in one day):

    Got it. Thanks very much, macmanx–everything is working now.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Calendar problem’ is closed to new replies.