Support » Plugin: Simple Calendar - Google Calendar Plugin » calendar not showing correct

  • Hi,

    Thanks for this great plugin! I’m using this plugin on
    Everything works fine for a while now. But I recently discovered that there are some issues with calendar now. You can find calendar widget I use on dutch reservation page and english reservation page. There are issues with event settings. I have setting “calendar start: 2 months after current”, but it shows only one month after current. When I put “calendar start: this month”, calendar starts previous month.
    Also, when you go to next month on website, it skips next month, so you have to click on back button to go back to skipped month, very strange…

    Any ideas/solutions please? Thanks in advance for help!

    Kind regards,


Viewing 10 replies - 1 through 10 (of 10 total)
  • When you check this topic, can you also check next topic please?

    I quote: “It means that the developer of Simple Calendar should fix the issue. He can use the hook for clear cache.

    Plugin Contributor Nick Young


    Hi first check your timezone settings:

    Make sure those are all set correctly.

    Hi Nick,

    Just checked: all settings are set to Brussels (GMT+1)… (so Google calendar, WordPress settings and Simple Calendar advanced settings set to site default (Europe/Brussels).

    I just resolved this issue myself 10 minutes ago. UTC+6 wasnt working for me (USA Central Timezone) so I had to change the wordpress settings to Chicago (not the city I am in but at least its the correct timezone) and then in Advanced settings had to change timezone to “Event Source Default” (none of the other options displayed the correct times).

    Hi Tim,

    I tried your solution: changed general wordpress timezone to UTC+1 and in calendar advanced settings “event source default”, but nothing changes :-//

    Hi Nick, any solution for this bug please?…

    UTC+6 didnt work for me either. Thats why I had to change to a city that I knew was in my correct timezone. I am using it for a city in Alabama, USA but the city wasnt offered as a choice so I chose Chicago, IL, USA. Is there a city in your timezone that you can chose instead of UTC+1 ?

    Hi Tim,

    I’m in Brussels and I can also choose this city in settings, so I think the issue is caused by something else and needs other solution.
    Thanks anyway! 😉


    I have a similar problem (on a development site, so I can’t show you).
    I set calendar start to 1 month after current, but it still starts at current month. (This month is empty but I suppose that’s correct, since I set the earliest event to same as calendar start date.)
    When I click next month it jumps TWO months, and when I then click previous month it goes back one month (and don’t show previous month-arrow). Current example: January (empty) [click next] -> March [click previous] -> February (where it was supposed to start).
    When I set starting date two months after current, the initial view is one month after current, jumping two months when clicking next.
    Current example: February (empty) [click next] -> April [click previous] -> March (where it was supposed to start).

    It seems to ‘simply’ offset a future starting date one month back. But only in initial view.

    A bit confusing, but I hope this could help some bug fixing 🙂


    Plugin Contributor Nick Young


    Advanced settings had to change timezone to “Event Source Default” (none of the other options displayed the correct times).

    There was actually an issue with this in the past. Does changing this setting around for anyone else work?

    Also, maybe try checking for theme and plugin conflicts just to be sure.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘calendar not showing correct’ is closed to new replies.