Support » Plugin: Simply Schedule Appointments » Calendar not appearing on smartphone

  • Resolved ebutow

    (@ebutow)


    I’m creating a smartphone version of my WP site, and I found that when I tap on my Book a Meeting button, the new window opens in Simply Schedule Appointments but the plugin doesn’t appear on the screen. Does SSA work on mobile devices or on desktop sites only? And if SSA does work on mobile devices, is there anything I’m missing that’s causing the plugin not to work?

    Thanks,
    Eric

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor Natalie MacLees

    (@nataliemac)

    Hello @ebutow,

    Simply Schedule Appointments should work fine on most mobile devices. We can’t support older versions of Safari, so if you’re using an iPhone, it will need to be an iPhone 6 or newer.

    It should work fine in other browsers on smart phones, as well, including Chrome and Firefox. If you’re having trouble with a device that should be working, please let us know and we’ll take a look and help troubleshoot. We’re also working on showing a more helpful error message in browsers that can’t support our app rather than just a blank screen.

    Hi, Natalie. I’m using the latest version of Safari on my iPhone 8, but all I see is the footer on the website. The footer is also screwed up, but I suspect that will be fixed once we can figure out why the plugin isn’t showing up. The URL is https://www.butow.net/book-a-meeting

    Thanks,
    Eric

    Plugin Contributor Natalie MacLees

    (@nataliemac)

    Hello @ebutow,

    The first thing that’s a little odd is that your footer shouldn’t be rendering on the full-screen appointment booking page at all. I’m not sure what it’s appearing there, but it likely doesn’t look the way you’d expect because the CSS for it is being stripped.

    This full-screen view is handy for folks who are having theme or plugin conflicts, but you’ll likely be happier with the appearance of the appointment booking form if you just use our [ssa_booking] shortcode to embed it in a regular page of the site so that your header and footer are still visible an accessible.

    And then finally, I’ve tested your page in Safari on both iPhone 6 and iPhone 8 and it renders just fine for me. I do get a couple of warnings in the debugger that some of your files are loading over http: instead of https: but I don’t think that would be causing Simply Schedule Appointments not to load at all.

    I’d be curious to see if embedding Simply Schedule Appointments in a page would fix the issue on your phone.

    If you’re familiar with debugging in the browser console, have a Mac, and are up for it, you might try using Safari on your computer to run the debugger for mobile Safari on your phone. (https://www.lifewire.com/activate-the-debug-console-in-safari-445798) That might give a helpful error message that might point the way to why this isn’t working on your phone.

    Other than that – do you have any out-of-the-ordinary settings on the phone I might try to replicate? Using a VPN, some kind of security settings, or anything like that?

    My iPhone is supervised so that may be the culprit. I’ll get the phone unsupervised and then find out if there are still problems. If I still have problems, I’ll run the debugger and see if I can get the error message. If you don’t hear from me, then you’ll know the supervision was the problem.

    Thanks,
    Eric

    pen001

    (@pen001)

    Hi there

    I am having issues with the calendar [month view] not appearing on smartphones – however works beautifully on desktop. The error message that shows after the plugin attempts to load is: Uh oh. We ran into a problem: Unable to get the settings.

    I have used the [SSA_booking] short code on a regular page of my site. The smartphones I have tried to load the calendar on are Samsung galaxy S7 and Samsung note 3 models, both have the latest updates (I haven’t got an apple device to try it out on). Is it possible you could help or advise what I may have missed during installation/setup?

    Thanks so much in advance!

    This is the page I would like some help with: http://www.designinglove.co/designinglove-co-schedule/

    Plugin Contributor Natalie MacLees

    (@nataliemac)

    Hello @pen001,

    I took a look at your page and it looks like you might be using the Disable REST API plugin, is that correct? Our plugin relies on the REST API to function, so that can’t be disabled.

    We’ll look into that plugin to see if there’s a way for us to get that working, but for now, if you disable that plugin, Simply Schedule Appointments should work just fine.

    pen001

    (@pen001)

    Hi Natalie

    Thank you so much for your help. I am indeed! I have white listed SSA in the Disable Rest API plugin and all works perfect now. Thank you again!

    Plugin Contributor Natalie MacLees

    (@nataliemac)

    Ok, great. I’m glad that worked for you. Let us know if you need anything else.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.