Support » Plugin: Events Made Easy Frontend Submit » Calendar nonresponsive

  • Resolved Ashod

    (@ashmtl)


    When the EVE front end form is used the calendar covers full screen and I get the following in the java-script console:
    JQMIGRATE: Migrate is installed, version 1.4.1
    6

    [Violation] Added non-passive event listener to a scroll-blocking <some> event. Consider marking event handler as ‘passive’ to make the page more responsive. See <URL>
    jquery.js?ver=1.12.4:2

    Uncaught Error: Method option does not exist on jQuery.datepicker
    at Function.error (jquery.js?ver=1.12.4:2)
    at a.fn.init.jQuery.fn.(/manage-events/wimc-submit-event/anonymous function) [as datepicker] (https://motoclub.ca/club/wp-content/themes/business-idea/assets/js/materialize.js?ver=1:1156:12)
    at emefs_deploy (emefs.js?ver=5.1.1:127)
    at HTMLDocument.<anonymous> ((index):523)
    at i (jquery.js?ver=1.12.4:2)
    at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4:2)
    at Function.ready (jquery.js?ver=1.12.4:2)
    at HTMLDocument.K (jquery.js?ver=1.12.4:2)
    error @ jquery.js?ver=1.12.4:2
    jQuery.fn.(anonymous function) @ materialize.js?ver=1:1156
    emefs_deploy @ emefs.js?ver=5.1.1:127
    (anonymous) @ (index):523
    i @ jquery.js?ver=1.12.4:2
    fireWith @ jquery.js?ver=1.12.4:2
    ready @ jquery.js?ver=1.12.4:2
    K @ jquery.js?ver=1.12.4:2
    tinymce.min.js?ver=4920-20181217:2 [Violation] Avoid using document.write(). https://developers.google.com/web/updates/2016/08/removing-document-write

    I did try in IE, FireFox and Chrome. The same result in all of them.
    Please advise.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Franky

    (@liedekef)

    Seems to me your theme is interfering with regular wordpress datepicker (see the mentioning of materialize.js). Based on the content of your page you need to update your theme.

    Thank you Franky for fast reply.
    I was using the business idea theme and it was updated.
    As soon as I replaced it with Twenty Nineteen theme, the calendar started to work as described. So the problem was the theme, not the update or the plugin.
    I will try to discuss the issue with the theme authors, unless you know how to make it work.
    Looks like I am getting a good grip on EVE and the more I learn, the more I like it. You have created an awesome plugin.
    Thank you.
    Ash.

    Plugin Author Franky

    (@liedekef)

    I just installed that theme and saw the same issues you have. It seems that theme is redefining lots of Datepicker functions (or functionality), see assets/js/materialize.js, “var Datepicker = function (_Component15) {”

    Of course the way they do it, it overrides the regular datepicker-call from jquery and thus causes issues because they don’t (or didn’t) foresee all datepicker calls/options in their wrapper.

    As a test, I removed the following 4 lines from materialize.js (around line 9641):

      M.Datepicker = Datepicker;
    
      if (M.jQueryLoaded) {
        M.initializeJqueryWrapper(Datepicker, 'datepicker', 'M_Datepicker');
      }

    and all started working as expected.

    This is amazing Franky. I never had such a good support as your’s. I will discuss with our club members and if they want to keep the “Business Idea” theme I will have to create a child theme to prevent the reverse of the changes on updates. But honestly I would prefer not to use this theme at all, because I am sure I will get other problems with it.
    Thank you again,
    Ash.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Calendar nonresponsive’ is closed to new replies.