Support » Theme: Neve » Calendar Legacy Widget error after update

  • Resolved adm96

    (@adm96)


    Good morning, I’ve updated the Neve theme (using a child with almost no difference) and I’m starting receiveing the automatic mails from wordpress that my website has a critic error.

    WordPress 5.8.2
    WKSpaghetti (versione 4.0.4)
    PHP 7.4.13

    Error details
    ====================
    Un errore di E_ERROR è stato causato nella line 98 del file /home/mhd-01/www.workingitaly.it/htdocs/wp-content/themes/neve/inc/views/layouts/layout_sidebar.php. Messaggio di errore: Uncaught Error: [] operator not supported for strings in /home/mhd-01/www.workingitaly.it/htdocs/wp-content/themes/neve/inc/views/layouts/layout_sidebar.php:98
    Stack trace:
    #0 /home/mhd-01/www.workingitaly.it/htdocs/wp-includes/class-wp-hook.php(305): Neve\Views\Layouts\Layout_Sidebar->add_body_class()
    #1 /home/mhd-01/www.workingitaly.it/htdocs/wp-includes/plugin.php(189): WP_Hook->apply_filters()
    #2 /home/mhd-01/www.workingitaly.it/htdocs/wp-includes/post-template.php(836): apply_filters()
    #3 /home/mhd-01/www.workingitaly.it/htdocs/wp-includes/post-template.php(595): get_body_class()
    #4 /home/mhd-01/www.workingitaly.it/htdocs/wp-includes/blocks/legacy-widget.php(113): body_class()
    #5 /home/mhd-01/www.workingitaly.it/htdocs/wp-includes/class-wp-hook.php(303): handle_legacy_widget_preview_iframe()
    #6 /home/mhd-01/www.workingitaly.it/htdocs/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters()
    #7 /home/mhd-01/www.workingitaly.it/htdocs/wp-includes/plugin.php(470): WP_Hook->do_action()
    #8 /home/mhd-01/www`

    Actually my website is working well with no issue but I’ve noticed that after the last update the WP Event Manager got broken by the Neve theme. Now the sidebar displays even in events page where in the past the wp event manager sidebar wasn’t in the bottom part. Also the single event template was a full page one, not contained like now (check the link below)

    https://www.workingitaly.it/concorsi/concorso-comune-di-livorno-5-profili-1-informatico-4-geometri/

    Is there some conflict between Neve and the way that WP Event Manager works?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hello @adm96!

    Thanks for choosing Neve!

    Unfortunately I am not able to replicate this issue, I don’t get any errors. The errors you receive are not only related to the theme, some of them are also related to WordPress itself. If you suspect this issue appeared after the last update, you could rollback the theme and check if this solves the issue.

    Have a nice day!

    Thread Starter adm96

    (@adm96)

    Can you please link me the Neve version 3.0.11? I can’t find any download about it and it was the last working version for me and the event plugin that I use

    Hello @adm96!

    You can find the latest version of the theme here.

    Thread Starter adm96

    (@adm96)

    I think there’s a misunderstanding. We’re talking about downgrade Neve, not installing the latest version. At the moment I’m unable to found the previous version (3.0.10 or 3.0.9)

    Hi @adm96!

    It was indeed a misunderstanding, sorry about that! One way to rollback the theme to a previous version is by going to Appearance -> Themes, clicking on Neve and clicking on the “Rollback to v3.1.0” button, as you can see here. This can be done multiple times, depending on the version you want to use.

    Have a nice day!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.