Support » Plugin: Simple Calendar - Google Calendar Plugin » calendar grid wrong (previous) month

  • Resolved palatin8

    (@palatin8)


    Reported earlier: Simcal in grid view (calendar start: this month) displays not the current but previous month in first impression. Clicking the link (angle) to next month skips the current month and changes the view to next to current month.

    For January you can help yourself setting calendar start to “this year”, but I need a solution for February and following.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Same issue here https://www.cbricany.cz/aktualne/
    I saw your website @palatin8 and your calendar started at January. Is that because of “start this year” or have you solved the issue?

    No solution yet. Setting calendar start to “this year” will only help until February, I’m afraid.

    This is working for me:

    Go to
    /wp-content/plugins/google-calendar-events/includes/abstracts/calendar.php

    find line 660
    $start_dt = Carbon::today( $this->timezone )->startOfMonth();

    and change it to
    $start_dt = Carbon::today( $this->timezone )->startOfMonth()->addHour();

    I now have calendar start this month, earliest event 1 month before start date, latest event 1 year after start date. Initial view and navigation between months as expected.

    Of course the change will be lost when you update GoogleCalendarEvents.

    Did you ever find a proper solution to this? Is this a known bug?

    I have a client site with the same problem and I’m wondering what to do…

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.