WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Calendar grid displaying 1st day only

[Resolved] Calendar grid displaying 1st day only

  • Hi there

    We updated the plugin and now only the first day of the month is showing in the calendar grid view. Preceeding blank cells are showing, but then just the info for the 1st. No output in the calendar after that, even the cells are missing.

    Confirmed on all months.

    I’ve checked the page source, and it’s not like they’re hidden – the 1st is literally the last <td> present, and there’s just the single <tr>.

    screenshot here

    Any pointers would be much appreciated!

    Thanks!

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Rob La Gatta

    @roblagatta

    Hey ollyb. That’s a weird one, and I’m not sure what could be causing it. I’m going to ask Jonah – a member of our team far more knowledgeable on dev-related matters than I – to take a look. Any chance you can post a link to the actual site, in the interim?

    Hi

    Thanks for getting back to me. The page is at http://yabangee.com/events/month/

    We went from version 2.0.9 to 2.0.11.

    Let me know if you need any further info!

    Many thanks

    Olly

    Hey ollyb,

    Two things:

    1. It looks like there may be some PHP errors that stopped the query from running in full. Can you switch WP_DEBUG in wp-config.php to true to see if there are errors on the page?

    2. It could be a plugin conflict. Have you tried deactivating all other plugins to see if that helps?

    Let me know. Thanks,
    Jonah

    Hi Jonah

    Thanks for the reply. I’ll have a go with WP_DEBUG and let you know how we get on. We’ve not tried disabling any other plugins as yet – unfortunately 9 plugins were accidentally updated at the same time, so I’m surprised more hasn’t broken!

    Will be in touch when I’ve had a chance to look at the debugging.

    Thanks

    Olly

    Hi Olly,

    That sounds good, let me know how it goes.

    – Jonah

    I set WP_DEBUG to true, but there was nothing different in the output.

    I’m open to any other suggestions!

    Hi ollyb,

    Ok, what about deactivating all other plugins? Have you tried that? Also, please try reverting to the Twenty Eleven/Twelve theme to see if it’s an issue with your theme. Let me know what you find.

    Thanks,
    Jonah

    Plugin Author Rob La Gatta

    @roblagatta

    Hey ollyb, any thoughts on Jonah’s last note? Did you get this sorted?

    HI

    Thanks for the responses. I haven’t had chance to test these out on the live site. I will probably need to make a copy and create a dev site in order to test out the various plugins/themes.

    Thanks for the suggestions, I hope to be able to try them in the next 48 hours.

    Sounds good ollyb, let us know how it goes.

    Thanks,
    Jonah

    Working now.

    Had the GeoMashup plugin installed, deactivating it fixed the issue. They released a new version and going from 1.5.2 to 1.5.3 fixed it.

    Thanks for your time on this.

    Hey ollyb,

    Glad to hear! Going to mark this as resolved but feel free to re-open if need be or create another thread if you need any other help.

    Thanks,
    Jonah

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Calendar grid displaying 1st day only’ is closed to new replies.