Support » Plugin: Redis Object Cache » Caching various virtualhost

  • Resolved armory1886

    (@armory1886)


    Maybe this get covered time ago but can’t find

    I’m struggling with this at the moment, since I have a bunch of sites, it works like a charm if I activate the redis cache (?) plug-in for one site only (foo.bar), however, when I set it active, it is for all of the sites simultaneously, and then everything gets redirected to the original site in which I activated the plug-in. (foobar.com/page —> foo.bar/page)

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    You probably need to set a different WP_REDIS_DATABASE for each site.

    armory1886

    (@armory1886)

    Thanks for you response
    I have tried setting

    define( ‘WP_REDIS_DATABASE’, 0);
    define( ‘WP_REDIS_DATABASE’, 1);

    for the two sites but didn’t help

    Status: Connected
    Client: PhpRedis (v4.2.0)
    Drop-in: Valid
    Ping: +PONG
    Redis Extension: 4.2.0
    Predis Client: 1.1.1
    PHP Version: 7.3.14-1~deb10u1
    Redis Version: 5.0.3
    Multisite: No
    Global Prefix: "wp_"
    Blog Prefix: "wp_"
    WP_REDIS_HOST: "127.0.0.1"
    WP_REDIS_PORT: "6379"
    WP_REDIS_DATABASE: 0
    Global Groups: {
        "0": "blog-details",
        "1": "blog-id-cache",
        "2": "blog-lookup",
        "3": "global-posts",
        "4": "networks",
        "5": "rss",
        "6": "sites",
        "7": "site-details",
        "8": "site-lookup",
        "9": "site-options",
        "10": "site-transient",
        "11": "users",
        "12": "useremail",
        "13": "userlogins",
        "14": "usermeta",
        "15": "user_meta",
        "16": "userslugs",
        "33": "blog_meta"
    }
    Plugin Author Till Krüss

    (@tillkruess)

    If you only have 2 sites and set the database for each, then try a full flush FLUSHALL, the issue should resolve itself afterwards.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.