Support » Plugin: Swift Performance Lite » Caching stops randomly, never completes

  • Resolved liswa

    (@liswa)


    The cache prebuild will never finish. Even manually clicking “start Prebuild Cache” will only do a few pages. Server disk space is not full.

    Whenever I check in on the cache its always on random amounts (usually low, like 60/430 pages). The pages haven’t usually been updated in the meantime.

    Settings:
    Caching enabled
    Disk Cache with Rewrites
    Early Loader on
    Time Based (12 hr expiry, 30min garbage collection)
    Cache for logged in users
    Browser cache enabled
    Gzip enabled
    Prebuild Cache Automatically on
    CDN General OFF
    Cloudflare on with Autopurge and everything set up as per https://swteplugins.com/docs/setting-up-cloudflare-with-swift/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Fred

    (@fredawd)

    It might related to your hosting enviroment, but without exactly seeing your configuration it is hard to say. Start with cleaning up your warmup table following this guide: https://swteplugins.com/docs/warmup-table/

    Then set Prebuild Speed on unlimited and don`t enable Limit Simultaneous Threads.
    Also disable generate Critical CSS as it should speed up prebuild as well.

    Thanks for the reply.

    My available options for Prebuild Speed are “Moderate”, “Reduced” and “Slow”, and it’s currently on moderate.

    It only ever gets to 1/2 threads (most often 0 though). I am on Cloud Dedicated (not shared) hosting currently, but was on a shared server for development. Could that be affecting my options?

    Plugin Contributor Fred

    (@fredawd)

    Sorry, my bad, ultimate speed is only available in Pro version. You may try to reinstall Swift and run autoconfig once again to be sure it detect new server enviroment.

    OK I did that (reinstalled, autoconfigured) and left it some time.

    Coming back the next day the site had cached only 115/525 discovered pages (I think it may just be pages people have visited in the meantime).

    Obviously I can’t manually initiate the caching and sit on that page every time it wants to clear itself, it’s too unreliable.

    Plugin Contributor Fred

    (@fredawd)

    Does your site has over 500 pages? Maybe you need to cleanup warmup table?

    You may also choose to cache pages on first visit, so second visitor get served cached pages. This is how most cache plugins work. To achieve this, enable Optimize in background. Also, make sure you disable Optimize Prebuild Only and Prebuild Cache Automatically.

    It was picking up some tag categories and product categories etc because of the reset (I did a full re-install)

    I have optimize in background and prebuild cache automatically on now, turned off optimize prebuild only.

    It seems to have gotten through the pages without stopping now.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.