Caching Problem, Site Displays Days-Old Version (3 posts)

  1. Christian
    Posted 1 year ago #

    Hello, I recently came across a problem with my site that seems to be related to caching.


    For the last few weeks, off and on, my front page (home) will display latest posts, but not really; it seems to stay a few days behind. Thus, my latest 3 or so posts, depending on how often I am publishing, won't show up on my homepage section. They do exist as published, as I can type in their links manually.

    Additional Info:
    I guess this has to do with caching, am I right? Now, sometimes when I am logged in I don't get this issue, but viewing from a different browser or my phone shows me this error.

    I am using a combination of caching and CDNs on this site. I have MaxCDN installed for larger files, CloudFlare for scripts and whatnot, and they are all tied together with the W3TC caching plugin.

    I don't even know where to begin to debug this problem. Can anybody point me in the right direction? I did try to look up this issue in the WordPress forum, but I don't even know the keywords or how to describe this problem, so my searches are not coming up with seemingly relevant results. Thanks in advance!

    Christian E.

  2. cubecolour
    Posted 1 year ago #

    It does sound like a cache issue. If you post on the forum for W3TC here at http://wordpress.org/support/plugin/w3-total-cache your question is more likely to be seen by the people who know W3TC best and should be able to advise you on how to proceed.

  3. Christian
    Posted 1 year ago #

    Thanks so much! I guess you're thinking it's a problem with that plugin, so I'll let you know how that goes :)

Topic Closed

This topic has been closed to new replies.

About this Topic