Support » Plugin: Redis Object Cache » Caching or Not

  • Resolved whpingel

    (@whpingel)


    I’ve hit a wall here as to whether or not I have object caching happening or not. When I look at Query Monitor I see this:

    Object Cache
    90.8% hit rate (21,050 hits, 2,136 misses)
    External object cache not in use
    The Redis extension for PHP is installed but is not in use by WordPress
    Opcode cache in use: Zend OPcache

    …however my diagnostics seem to show everything is hooked up:

    Status: Connected
    Client: PhpRedis (v5.3.4)
    Drop-in: Valid
    Disabled: No
    Ping: 1
    Errors: []
    PhpRedis: 5.3.4
    Predis: 1.1.9
    Credis: Not loaded
    PHP Version: 7.4.26
    Plugin Version: 2.0.22
    Redis Version: 6.2.6
    Multisite: No
    Metrics: Enabled
    Metrics recorded: 41
    Filesystem: Working
    Global Prefix: "wp_****_"
    Blog Prefix: "wp_****_"
    WP_REDIS_HOST: "127.0.0.1"
    WP_REDIS_PORT: 6379
    WP_REDIS_DATABASE: 0
    WP_REDIS_TIMEOUT: 1
    WP_REDIS_READ_TIMEOUT: 1
    WP_REDIS_PREFIX: "****"
    WP_CACHE_KEY_SALT: "****"
    Global Groups: [
        "blog-details",
        "blog-id-cache",
        "blog-lookup",
        "global-posts",
        "networks",
        "rss",
        "sites",
        "site-details",
        "site-lookup",
        "site-options",
        "site-transient",
        "users",
        "useremail",
        "userlogins",
        "usermeta",
        "user_meta",
        "userslugs",
        "redis-cache",
        "blog_meta"
    ]
    Ignored Groups: [
        "counts",
        "plugins",
        "themes"
    ]
    Unflushable Groups: []
    Drop-ins: [
        "Query Monitor Database Class v by ",
        "Redis Object Cache Drop-In v2.0.22 by Till Krüss"
    ]

    So long of the short I guess I’m curious if anyone else has every run into this. When I look at the Redis logs in Plesk I am not seeing or at least seeing anything that would appear to be caching the site. I’ve been googling and testing things for the past couple days but can’t seem to make headway on this. Any assistance would be appreciated.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    Hi!

    Status: Connected mean the object cache is being used, ignore what Query Monitor says.

    However Metrics recorded: 41 is suspicious, a 3rd party plugin may be flushing your cache continuously and you’re not building up any significant cache.

    Are you seeing metrics under Settings > Redis?

    Thread Starter whpingel

    (@whpingel)

    Hi Till,

    I am seeing this now: Metrics recorded: 169 under Metrics.

    Thanks for clearing up the Query Monitor deal none the less, was driving me nuts.

    -Wally

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.